aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD19
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6893f5a94433..d2754cf817d6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brother-dcpl3550cdw
pkgdesc = CUPS driver for Brother DCP-L3550CDW
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://support.brother.com/g/b/producttop.aspx?c=eu_ot&lang=en&prod=dcpl3550cdw_eu
arch = x86_64
license = unknown
diff --git a/PKGBUILD b/PKGBUILD
index dede0b993085..2901068c7330 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname="brother-dcpl3550cdw"
pkgver="1.0.2"
-pkgrel=1
+pkgrel=2
pkgdesc="CUPS driver for Brother DCP-L3550CDW"
arch=('x86_64')
url="https://support.brother.com/g/b/producttop.aspx?c=eu_ot&lang=en&prod=dcpl3550cdw_eu"
@@ -17,24 +17,25 @@ md5sums=("155eed84f5cbd7f406582d83c1c5c2d3")
package() {
# Using /usr/share instead of /opt
- mkdir -p "$pkgdir/usr/share"
- cp -R "$srcdir/opt/brother" "$pkgdir/usr/share"
- sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/${_model}/cupswrapper/brother_lpdwrapper_${_model}"
- sed -i 's|\\\/opt\\\/|\\\/usr\\\/|' "$pkgdir/usr/share/brother/Printers/${_model}/lpd/filter_${_model}"
+ mkdir -p "$pkgdir/opt/brother"
+ cp -R "$srcdir/opt/brother" "$pkgdir/opt"
# symlink for lpdwrapper so it correctly figures out the printer model from the path
install -d "$pkgdir/usr/lib/cups/filter/"
- ln -s "/usr/share/brother/Printers/${_model}/cupswrapper/brother_lpdwrapper_${_model}" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${_model}"
+ ln -s "/opt/brother/Printers/${_model}/cupswrapper/brother_lpdwrapper_${_model}" "$pkgdir/usr/lib/cups/filter/brother_lpdwrapper_${_model}"
# symlink for the PPD
- install -d "$pkgdir/usr/share/cups/model/"
- ln -s "/usr/share/brother/Printers/${_model}/cupswrapper/brother_${_model}_printer_en.ppd" "$pkgdir/usr/share/cups/model/"
+ install -d "$pkgdir/usr/share/cups/model/Brother"
+ ln -s "/opt/brother/Printers/${_model}/cupswrapper/brother_${_model}_printer_en.ppd" "$pkgdir/usr/share/cups/model/Brother"
# a couple architecture-specific symlinks
#ln -s "/usr/share/brother/Printers/${_model}/lpd/$CARCH/brprintconflsr3" "$pkgdir/usr/share/brother/Printers/${_model}/lpd/"
#ln -s "/usr/share/brother/Printers/${_model}/lpd/$CARCH/rawtobr3" "$pkgdir/usr/share/brother/Printers/${_model}/lpd/"
# symlink for inf because it tries to execute it there
- ln -s "/usr/share/brother/Printers/${_model}/inf" "$pkgdir/usr/share/brother/Printers/${_model}/lpd/"
+ ln -s "/opt/brother/Printers/${_model}/inf" "$pkgdir/opt/brother/Printers/${_model}/lpd/"
+
+ mkdir -p "${pkgdir}/usr/bin"
+ install "${srcdir}/usr/bin/brprintconf_${_model}" "${pkgdir}/usr/bin/"
}