summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c7f6aca23ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = brother-hll2310d
+ pkgdesc = Brother HL-L2310D CUPS driver
+ pkgver = 4.0.0
+ pkgrel = 1
+ url = http://www.brother.com
+ arch = x86_64
+ arch = i686
+ license = custom:Brother
+ depends = perl
+ depends = bash
+ depends = ghostscript
+ depends = lib32-glibc
+ source = https://download.brother.com/welcome/dlf103531/hll2310dpdrv-4.0.0-1.i386.rpm
+ md5sums = 786ededd9b19d559dcb49160bb81c8a2
+
+pkgname = brother-hll2310d
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..26fa8a59a7c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Benedykt 'b3niup' PrzybyƂo <b3niup@gmail.com>
+# based on brother-hll2300d by Mykola Bespaliuk (kolkabes [at] gmail [dot] com)
+pkgname=brother-hll2310d
+pkgver=4.0.0
+pkgrel=1
+pkgdesc="Brother HL-L2310D CUPS driver"
+url="http://www.brother.com"
+arch=('x86_64' 'i686')
+depends=('perl' 'bash' 'ghostscript')
+license=('custom:Brother')
+source=(
+ https://download.brother.com/welcome/dlf103531/hll2310dpdrv-${pkgver}-${pkgrel}.i386.rpm
+)
+md5sums=(
+ '786ededd9b19d559dcb49160bb81c8a2'
+)
+
+if [[ "$CARCH" == "x86_64" ]]; then
+ depends+=('lib32-glibc')
+fi
+
+package() {
+ mkdir -p "${pkgdir}/opt"
+ cp -R "${srcdir}/opt/brother" "${pkgdir}/opt/brother"
+
+ cd ${pkgdir}/opt/brother/Printers/HLL2310D/lpd
+ for i in brprintconflsr3 rawtobr3; do ln -s ${CARCH}/$i .; done
+ cd -
+ mkdir -p "${pkgdir}/usr/lib/cups/filter"
+ echo "#! /opt/brother/Printers/HLL2310D/cupswrapper/lpdwrapper" > "${srcdir}/filter-shim"
+ install -m 0755 -o root -g root "${srcdir}/filter-shim" "${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_HLL2310D"
+
+ mkdir -p "${pkgdir}/usr/share/ppd/cupsfilters"
+ install -m 0644 -o root -g root "${srcdir}/opt/brother/Printers/HLL2310D/cupswrapper/brother-HLL2310D-cups-en.ppd" "${pkgdir}/usr/share/ppd/cupsfilters"
+}
+