summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--brother-hll2380dw.patch24
3 files changed, 18 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0bffce72e467..97705dac5f0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,7 +11,7 @@ pkgbase = brother-hll2380dw
source = brother-hll2380dw.patch
source = http://download.brother.com/welcome/dlf101770/hll2380dwcupswrapper-3.2.0-1.i386.rpm
source = http://download.brother.com/welcome/dlf101769/hll2380dwlpr-3.2.0-1.i386.rpm
- md5sums = ecd2aa8403e50a739f20c76fc9032495
+ md5sums = 6fdeafe78178d6335de2f42d859673be
md5sums = 3fe2c6b93ec0acc7886beaa314212fca
md5sums = 1cf4aa246d05da5e8d3bc280d000695e
diff --git a/PKGBUILD b/PKGBUILD
index ff5da2f33ddb..b340d3829bbf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@ depends_x86_64=('lib32-glibc')
source=(brother-hll2380dw.patch
http://download.brother.com/welcome/dlf101770/hll2380dwcupswrapper-${pkgver//_/-}.i386.rpm
http://download.brother.com/welcome/dlf101769/hll2380dwlpr-${pkgver//_/-}.i386.rpm)
-md5sums=('ecd2aa8403e50a739f20c76fc9032495'
+md5sums=('6fdeafe78178d6335de2f42d859673be'
'3fe2c6b93ec0acc7886beaa314212fca'
'1cf4aa246d05da5e8d3bc280d000695e')
prepare() {
@@ -25,7 +25,7 @@ package() {
cp -R "$srcdir/opt/brother" "$pkgdir/usr/share/brother"
- ln -s "/usr/share/brother/Printers/HLL2360D/cupswrapper/brother_lpdwrapper_HLL2360D" "$pkgdir/usr/lib/cups/filter/"
- ln -s "/usr/share/brother/Printers/HLL2360D/cupswrapper/brother-HLL2360D-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
+ ln -s "/usr/share/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW" "$pkgdir/usr/lib/cups/filter/"
+ ln -s "/usr/share/brother/Printers/HLL2380DW/cupswrapper/brother-HLL2380DW-cups-en.ppd" "$pkgdir/usr/share/cups/model/"
}
diff --git a/brother-hll2380dw.patch b/brother-hll2380dw.patch
index 24ccbd0c00cc..bc32b6ec284e 100644
--- a/brother-hll2380dw.patch
+++ b/brother-hll2380dw.patch
@@ -1,6 +1,6 @@
-diff -aur pkg.pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW pkg.new/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW
---- pkg.pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW 2016-08-20 21:56:06.302059556 -0400
-+++ pkg.new/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW 2016-08-20 21:59:18.332061342 -0400
+diff -aur pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW new/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW
+--- pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW 2016-08-21 00:24:32.495475668 -0400
++++ new/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwrapper_HLL2380DW 2016-08-21 00:26:23.022143362 -0400
@@ -43,15 +43,7 @@
$width=-1;
$height=-1;
@@ -14,15 +14,19 @@ diff -aur pkg.pristine/opt/brother/Printers/HLL2380DW/cupswrapper/brother_lpdwra
-
-$basedir =~ s/$PRINTER\/cupswrapper\/.*$/$PRINTER\//g;
-
-+my $basedir = "/usr/share/brother/printers/HLL2380DW"
++my $basedir = "/usr/share/brother/Printers/HLL2380DW/";
%units = ( pt => \&pt2dot,
mm => \&mm2dot,
-@@ -85,6 +77,7 @@
+@@ -83,10 +75,7 @@
+ $CUPSINPUT=$ARGV[7];
+ }
+-
+-$PRINTER =~ s/^\/opt\/.*\/Printers\///g;
+-$PRINTER =~ s/\/cupswrapper//g;
+-$PRINTER =~ s/\///g;
++$PRINTER = "HLL2380DW";
- $PRINTER =~ s/^\/opt\/.*\/Printers\///g;
-+$PRINTER =~ s/^\/usr\/share\/.*\/Printers\///g;
- $PRINTER =~ s/\/cupswrapper//g;
- $PRINTER =~ s/\///g;
-
+ for (my $i = 0 ; $i < @ARGV ; $i ++){
+ logprint( 0 , "ARG$i = $ARGV[$i]\n");