summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--brother-mfc-j265w.install13
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e9ff42f18d25
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Sat Sep 19 09:53:48 UTC 2015
+pkgbase = brother-mfc-j265w
+ pkgdesc = LPR and CUPS driver for the Brother MFC-J265W
+ pkgver = 1.1.3
+ pkgrel = 1
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-j265w.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ source = http://download.brother.com/welcome/dlf006542/mfcj265wlpr-1.1.3-1.i386.deb
+ source = http://download.brother.com/welcome/dlf006544/mfcj265wcupswrapper-1.1.3-1.i386.deb
+ md5sums = 036138c0f659283aa492eddb1495edf6
+ md5sums = c1459408fbf72a588d72a4048cb801de
+
+pkgname = brother-mfc-j265w
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ecac8ce49ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Michael Heyns <beanaroo@gmail.com>
+
+pkgname="brother-mfc-j265w"
+pkgver="1.1.3"
+pkgrel=1
+_revision=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J265W"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license='unknown'
+install='brother-mfc-j265w.install'
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
+source=(
+ "http://download.brother.com/welcome/dlf006542/mfcj265wlpr-1.1.3-1.i386.deb"
+ "http://download.brother.com/welcome/dlf006544/mfcj265wcupswrapper-1.1.3-1.i386.deb"
+)
+md5sums=('036138c0f659283aa492eddb1495edf6'
+ 'c1459408fbf72a588d72a4048cb801de')
+
+build() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+}
+
+package() {
+ cd $srcdir || return 1
+ [ -d "mfcj265w" ] || (mkdir mfcj265w || return 1)
+ for i in *.tar.gz;do tar xfz $i -C mfcj265w;done || return 1
+ cd mfcj265w || return 1
+ cd usr/local/Brother/Printer/mfcj265w || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfcj265w || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' ./inf/setupPrintcapij || return 1
+ cp -rf $srcdir/mfcj265w/usr/ $pkgdir/ || return 1
+}
diff --git a/brother-mfc-j265w.install b/brother-mfc-j265w.install
new file mode 100644
index 000000000000..8f9d323cd273
--- /dev/null
+++ b/brother-mfc-j265w.install
@@ -0,0 +1,13 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /usr/local/Brother/Printer/mfcj265w/cupswrapper/cupswrappermfcj265w >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface
+(http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}