summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--brother-mfc-j6510dw.install12
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae404ad00f08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = brother-mfc-j6510dw
+ pkgdesc = LPR and CUPS driver for the Brother MFC-J6510DW
+ pkgver = 3.0.0
+ pkgrel = 3
+ url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
+ install = brother-mfc-j6510dw.install
+ arch = i686
+ arch = x86_64
+ license = unknown
+ depends = tcsh
+ depends = deb2targz
+ depends = perl
+ depends = a2ps
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfcj6510dwlpr-3.0.0-1.i386.deb
+ source = http://www.brother.com/pub/bsc/linux/dlf/mfcj6510dwcupswrapper-3.0.0-1.i386.deb
+ md5sums = b45aa1c4524eceecaf8f620a3abe1c61
+ md5sums = 753494cf9dabdc35987bff23aa28836b
+
+pkgname = brother-mfc-j6510dw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a8df2fd605d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Lswest lswest34 <at> gmail.com
+# Based on brother-mfc-j6710dw package from AUR
+
+_model="j6510dw"
+pkgname="brother-mfc-$_model"
+pkgver="3.0.0"
+pkgrel=3
+_revision=1
+pkgdesc="LPR and CUPS driver for the Brother MFC-J6510DW"
+url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
+arch=('i686' 'x86_64')
+license=('unknown')
+install="brother-mfc-${_model}.install"
+depends=('tcsh' 'deb2targz' 'perl' 'a2ps')
+source=("http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}lpr-${pkgver}-${_revision}.i386.deb"
+ "http://www.brother.com/pub/bsc/linux/dlf/mfc${_model}cupswrapper-${pkgver}-${_revision}.i386.deb")
+
+build() {
+ deb2targz *.deb >/dev/null || return 1
+ rm -f *.deb || return 1
+ cd $srcdir || return 1
+ [ -d "mfc${_model}" ] || (mkdir mfc${_model} || return 1)
+ for i in *.tar.gz;do tar xfz $i -C mfc${_model};done || return 1
+ cd mfc${_model} || return 1
+ cd opt/brother/Printers/mfc${_model} || return 1
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfc${_model} || return 1
+ perl -i -pe 's#printcap\.local#printcap#g' $srcdir/mfc${_model}/opt/brother/Printers/mfc${_model}/inf/setupPrintcapij || return 1
+}
+package() {
+ cp -rf $srcdir/mfc${_model}/usr/ $pkgdir/ || return 1
+ cp -rf $srcdir/mfc${_model}/opt/ $pkgdir/ || return 1
+}
+md5sums=('b45aa1c4524eceecaf8f620a3abe1c61'
+ '753494cf9dabdc35987bff23aa28836b')
diff --git a/brother-mfc-j6510dw.install b/brother-mfc-j6510dw.install
new file mode 100644
index 000000000000..ec654c67a6b3
--- /dev/null
+++ b/brother-mfc-j6510dw.install
@@ -0,0 +1,12 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfcj6510dw/cupswrapper/cupswrappermfcj6510dw >/dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}