summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
-rw-r--r--brother-mfc-l3710cw.install15
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e5cb6397ed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = brother-mfc-l3710cw
+ pkgdesc = LPR and CUPS drivers for the Brother MFC-L3710CW
+ pkgver = 1.0.0
+ pkgrel = 0
+ url = http://support.brother.com/g/s/id/linux/en/index.html
+ install = brother-mfc-l3710cw.install
+ arch = i686
+ arch = x86_64
+ license = custom:brother
+ license = GPL
+ makedepends = perl
+ makedepends = tar
+ depends = cups
+ source = https://download.brother.com/welcome/dlf103930/mfcl3710cwpdrv-1.0.2-0.i386.deb
+ md5sums = 3c9df04884b75b7116adb3a0a7916c80
+
+pkgname = brother-mfc-l3710cw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55c6c7cc0e6e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: Kurt McAlpine <kurt at linux dot com>
+# This uses modified code from package brother-mfc-9335cdw by Leo Pham <regretfulumbrella at gmail dot com>
+pkgname=brother-mfc-l3710cw
+pkgver=1.0.0
+pkgrel=0
+pkgdesc='LPR and CUPS drivers for the Brother MFC-L3710CW'
+arch=('i686' 'x86_64')
+url='http://support.brother.com/g/s/id/linux/en/index.html'
+license=('custom:brother' 'GPL')
+depends=('cups')
+makedepends=('perl' 'tar')
+install='brother-mfc-l3710cw.install'
+source=('https://download.brother.com/welcome/dlf103930/mfcl3710cwpdrv-1.0.2-0.i386.deb')
+md5sums=('3c9df04884b75b7116adb3a0a7916c80')
+
+package() {
+ ar x mfcl3710cwpdrv-1.0.2-0.i386.deb && tar xzvf data.tar.gz
+
+ # Patch filenames to work on Arch
+ cd opt/brother/Printers/mfcl3710cw
+ perl -i -pe 's#/etc/init.d#/etc/rc.d#g' ./cupswrapper/cupswrappermfcl3710cw
+ perl -i -pe 's#printcap\.local#printcap#g' ./inf/setupPrintcapij
+
+ cp -rf $srcdir/usr/ $pkgdir/
+ cp -rf $srcdir/opt/ $pkgdir/
+}
diff --git a/brother-mfc-l3710cw.install b/brother-mfc-l3710cw.install
new file mode 100644
index 000000000000..accd131430d8
--- /dev/null
+++ b/brother-mfc-l3710cw.install
@@ -0,0 +1,15 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ /opt/brother/Printers/mfcl3710cw/cupswrapper/cupswrappermfcl3710cw > /dev/null
+ if [ "$?" -eq 0 ]; then
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via "
+ printf "the CUPS web interface (http://localhost:631).\n"
+ printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Make sure org.cups.cupsd.service is enabled "
+ printf "and started, in order for printing to work.\n"
+ else
+ printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
+ fi
+}