summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
-rw-r--r--brother-mfc-l8900cdw.install12
3 files changed, 26 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55b87427962f..d18b04f088dc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = brother-mfc-l8900cdw
pkgdesc = LPR and CUPS driver for the Brother MFC-L8900CDW
pkgver = 1.2.0
- pkgrel = 0
+ pkgrel = 1
url = http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html
- install = brother-mfc-l8900cdw.install
arch = i686
arch = x86_64
- license = EULA
- depends = tcsh
- depends = perl
- depends = a2ps
- depends = lib32-libcups
- source = mfcl8900cdwlpr-1.2.0-0.i386.rpm::http://download.brother.com/welcome/dlf103216/mfcl8900cdwlpr-1.2.0-0.i386.rpm
- source = mfcl8900cdwcupswrapper-1.3.0-0.i386.rpm::http://download.brother.com/welcome/dlf103225/mfcl8900cdwcupswrapper-1.3.0-0.i386.rpm
+ license = GPL2
+ license = custom:Brother EULA
+ depends = cups
+ source = http://download.brother.com/welcome/dlf103216/mfcl8900cdwlpr-1.2.0-0.i386.rpm
+ source = http://download.brother.com/welcome/dlf103225/mfcl8900cdwcupswrapper-1.3.0-0.i386.rpm
sha256sums = 82cb8b3710523b546e40e1280275ecc1689b50294644d6b81a25cbffc385e8c4
sha256sums = d92bbb84b6b66aad097b705dd6b2a53d19cab79fde546ad7a25e4952ee4547fa
+ depends_x86_64 = lib32-glibc
pkgname = brother-mfc-l8900cdw
diff --git a/PKGBUILD b/PKGBUILD
index 80bc29830fab..9f2234a673cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,30 @@
# Maintainer: Matteo Bonora <bonora.matteo@gmail.com>
-model="l8900cdw"
-pkgname="brother-mfc-${model}"
+_model="l8900cdw"
+pkgname="brother-mfc-${_model}"
pkgver="1.2.0"
-_cupsver="1.3.0"
-pkgrel=0
-_revision=0
+pkgrel=1
pkgdesc="LPR and CUPS driver for the Brother MFC-L8900CDW"
url="http://welcome.solutions.brother.com/bsc/public_s/id/linux/en/index.html"
arch=('i686' 'x86_64')
-license=('EULA')
-install="brother-mfc-${model}.install"
-depends=('tcsh' 'perl' 'a2ps' 'lib32-libcups')
-source=("mfc${model}lpr-${pkgver}-${_revision}.i386.rpm::http://download.brother.com/welcome/dlf103216/mfc${model}lpr-${pkgver}-${_revision}.i386.rpm"
- "mfc${model}cupswrapper-${_cupsver}-${_revision}.i386.rpm::http://download.brother.com/welcome/dlf103225/mfc${model}cupswrapper-${_cupsver}-${_revision}.i386.rpm")
+license=('GPL2' 'custom:Brother EULA')
+depends=('cups')
+depends_x86_64=('lib32-glibc')
+source=(http://download.brother.com/welcome/dlf103216/mfc${_model}lpr-${pkgver}-0.i386.rpm
+ http://download.brother.com/welcome/dlf103225/mfc${_model}cupswrapper-1.3.0-0.i386.rpm)
sha256sums=('82cb8b3710523b546e40e1280275ecc1689b50294644d6b81a25cbffc385e8c4'
'd92bbb84b6b66aad097b705dd6b2a53d19cab79fde546ad7a25e4952ee4547fa')
-
package() {
- cp -rf $srcdir/usr/ $pkgdir/ || return 1
- cp -rf $srcdir/opt/ $pkgdir/ || return 1
+ install -d ${pkgdir}/usr/share/cups/model/Brother
+ install -d ${pkgdir}/usr/share/ppd/Brother
+ install -d ${pkgdir}/usr/lib/cups/filter
+
+ install -Dm755 ${srcdir}/usr/bin/brprintconf_mfc${_model} ${pkgdir}/usr/bin/brprintconf_mfc${_model}
+ install -Dm644 ${srcdir}/opt/brother/Printers/mfc${_model}/cupswrapper/brother_mfc${_model}_printer_en.ppd ${pkgdir}/usr/share/cups/model/Brother
+ install -Dm644 ${srcdir}/opt/brother/Printers/mfc${_model}/cupswrapper/brother_mfc${_model}_printer_en.ppd ${pkgdir}/usr/share/ppd/Brother
+
+ ln -s /opt/brother/Printers/mfc${_model}/cupswrapper/brother_lpdwrapper_mfc${_model} ${pkgdir}/usr/lib/cups/filter/brother_lpdwrapper_mfc${_model}
+
+ cp -r ${srcdir}/opt ${pkgdir}/opt
}
diff --git a/brother-mfc-l8900cdw.install b/brother-mfc-l8900cdw.install
deleted file mode 100644
index 915bdd828932..000000000000
--- a/brother-mfc-l8900cdw.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- post_upgrade;
-}
-
-post_upgrade() {
- /opt/brother/Printers/mfcl8900cdw/cupswrapper/cupswrappermfcl8900cdw >/dev/null
- if [ "$?" -eq 0 ]; then
- printf "\033[1m\033[32m\x3d\x3d\x3e\033\1330m Done. The printer should be visible now via the CUPS-webinterface (http://localhost:631)\n"
- else
- printf "\033[1m\032[32m\x3d\x3d\x3e\033\1330m Something went wrong...\n"
- fi
-}