summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD4
-rw-r--r--brother-mfc240c.install4
-rw-r--r--brother-mfc240c.patch46
3 files changed, 45 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1aa617451616..e78445e52b4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ license=('GPL')
install="brother-mfc240c.install"
arch=('i686' 'x86_64')
depends_x86_64=('lib32-glibc')
-md5sums=('2856ad6fbe41b6ce01b1c0af3c7f94ef'
+md5sums=('55cba82f12929af901e8c489ffa7ca91'
'207cf1eb6bbab8d2ecafd8a2b5bc8f4b'
'e2564327cb7fc6501ca9657080855322')
@@ -34,7 +34,7 @@ package() {
rm "$pkgdir/usr/share/brother/Printer/mfc240c/cupswrapper/cupswrappermfc240c"
rm "$pkgdir/usr/share/brother/Printer/mfc240c/inf/setupPrintcapij"
- install -m 644 -D ppd_file "$pkgdir/usr/share/cups/model/MFC240C.ppd"
+ install -m 644 -D ppd_file "$pkgdir/usr/share/cups/model/brmfc240c.ppd"
install -m 755 -D wrapper "$pkgdir/usr/lib/cups/filter/brlpdwrappermfc240c"
}
diff --git a/brother-mfc240c.install b/brother-mfc240c.install
index f0af866b5dfa..eb7147ca3a26 100644
--- a/brother-mfc240c.install
+++ b/brother-mfc240c.install
@@ -8,10 +8,10 @@ post_install() {
__port="usb:/dev/usb/lp0"
fi
- lpadmin -p MFC240C -E -v $__port -P /usr/share/cups/model/MFC240C.ppd
+ lpadmin -p MFC240C -E -v $__port -P /usr/share/cups/model/brmfc240c.ppd
echo "If CUPS is not running now, start it after installation"
echo "and type command:"
- echo " lpadmin -p MFC240C -E -v URL -P /usr/share/cups/model/MFC240C.ppd"
+ echo " lpadmin -p MFC240C -E -v URL -P /usr/share/cups/model/brmfc240c.ppd"
echo "where URL can be found using command:"
echo " lpinfo -v | grep -i 'Brother'"
echo "You can also register new printer using web interface at:"
diff --git a/brother-mfc240c.patch b/brother-mfc240c.patch
index 61d4e9bd41d5..1db8a1c22d1c 100644
--- a/brother-mfc240c.patch
+++ b/brother-mfc240c.patch
@@ -1,5 +1,5 @@
---- old_usr/local/Brother/Printer/mfc240c/cupswrapper/cupswrappermfc240c 2016-02-24 21:02:31.352003704 -0600
-+++ usr/local/Brother/Printer/mfc240c/cupswrapper/cupswrappermfc240c 2016-02-24 21:23:16.875313191 -0600
+--- old_usr/local/Brother/Printer/mfc240c/cupswrapper/cupswrappermfc240c 2016-05-30 10:51:02.171260973 -0500
++++ usr/local/Brother/Printer/mfc240c/cupswrapper/cupswrappermfc240c 2016-05-30 10:40:47.737965976 -0500
@@ -23,6 +23,7 @@
device_name=`echo $printer_name | eval sed -e 's/MFC/MFC-/' -e 's/DCP/DCP-/' -e 's/FAX/FAX-/'`
pcfilename=`echo $printer_name | tr -d '[A-Z]'`
@@ -47,11 +47,11 @@
*UIConstraints: *BRColorMediaType Transparencies *Resolution Photo
*UIConstraints: *BRColorMediaType Transparencies *Resolution Highest
--
--
--ENDOFPPDFILE_END
+ENDOFPPDFILE1
+-
+-ENDOFPPDFILE_END
+-
+if /bin/false; then
chmod 644 $ppd_file_name
@@ -68,6 +68,42 @@
#! /bin/sh
#
# Copyright (C) 2005 Brother. Industries, Ltd.
+@@ -756,25 +741,25 @@
+ INPUT_TEMP_PS=\`mktemp /tmp/br_input_ps.XXXXXX\`
+
+ nup="cat"
+-if [ "`echo \$5 | grep 'Nup='`" != '' ] && [ \$NUPENABLE != 0 ]; then
++if [ "\`echo \$5 | grep 'Nup='\`" != '' ] && [ \$NUPENABLE != 0 ]; then
+
+- if [ "`echo \$5 | grep 'Nup=64'`" != '' ]; then
++ if [ "\`echo \$5 | grep 'Nup=64'\`" != '' ]; then
+ nup="psnup -64"
+- elif [ "`echo \$5 | grep 'Nup=32'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=32'\`" != '' ]; then
+ nup="psnup -32"
+- elif [ "`echo \$5 | grep 'Nup=25'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=25'\`" != '' ]; then
+ nup="psnup -25"
+- elif [ "`echo \$5 | grep 'Nup=16'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=16'\`" != '' ]; then
+ nup="psnup -16"
+- elif [ "`echo \$5 | grep 'Nup=8'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=8'\`" != '' ]; then
+ nup="psnup -8"
+- elif [ "`echo \$5 | grep 'Nup=6'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=6'\`" != '' ]; then
+ nup="psnup -6"
+- elif [ "`echo \$5 | grep 'Nup=4'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=4'\`" != '' ]; then
+ nup="psnup -4"
+- elif [ "`echo \$5 | grep 'Nup=2'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=2'\`" != '' ]; then
+ nup="psnup -2"
+- elif [ "`echo \$5 | grep 'Nup=1'`" != '' ]; then
++ elif [ "\`echo \$5 | grep 'Nup=1'\`" != '' ]; then
+ nup="cat"
+ fi
+ echo "NUP=\$nup" >>\$LOGFILE
@@ -798,25 +783,25 @@
cat > \$INPUT_TEMP_PS
fi