summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--LICENSE7
-rw-r--r--PKGBUILD66
-rw-r--r--brother-ql1100nwb.install10
5 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..03ecb95f3a9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = brother-ql1100nwb
+ pkgdesc = LPR and CUPS driver for Brother QL-1100NWB label printer
+ pkgver = 2.1.4r0
+ pkgrel = 1
+ url = http://solutions.brother.com/linux/en_us/
+ install = brother-ql1100nwb.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = cups
+ depends = lib32-glibc
+ source = http://download.brother.com/welcome/dlfp100576/ql1110nwbpdrv-2.1.4-0.i386.rpm
+ source = LICENSE
+ sha256sums = 560f71c6c6785e10e1696fee0096fb7ef9592d2dd5beb90fc9cd67200cc921c3
+ sha256sums = cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811
+
+pkgname = brother-ql1100nwb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..99ef7bc454dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/*.tar.gz
+/*.tar.xz
+/*.rpm
+/pkg/
+/src/
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8c61cbac9784
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,7 @@
+This Agreement provides terms and conditions for license grant from Brother Industries, Ltd ("Broher"). Brother, who owns all copyrights to the software that is distributed with this Agreement ("Software") to recipients thereof ("User"), for use of the Software. User shall have the right to use the Software only in accordance with the terms and conditions of this Agreement. Any use by User of the Software shall be deemed as its agreement hereto.
+
+Brother retains any and all copyrights to the Software. In no case this Agreement shall be construed to assign or otherwise transfer from Brother to User any copyrights or other intellectual property rights to whole or any part of the Software.
+
+Brother grants User a non-exclusive license: to reproduce and/or distribute (via Internet or in any other manner) the Software. Further, Brother grants User a non-exclusive license to modify, alter, translate or otherwise prepare derivative works of the Software and to reproduce and distribute (via Internet or in any other manner) such modification, alteration, translation or other derivative works for any purpose.
+
+The license of the Software from Brother hereunder is granted "AS IS." BROTHER HEREBY DISCLAIMS ANY WARRANTIES WITH RESPECT TO THE SOFTWARE, EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO WARRANTY FOR THE QUALITY, MERCHANTABILITY, FITNESS FOR PARTICULAR PURPOSE OR NON-INFRINGEMENT. Brother shall have no liability in contract, tort (including negligence or breach of statutory duty) or otherwise for any interruption of use, loss of data, or for any indirect, incidental, punitive or consequential loss or damage, or for any loss of profit, revenue, data, goodwill or anticipated savings that arises under, out of, or in contemplation of this Agreement or otherwise arises due to any error, inaccuracy or defect in the Software even if Brother has been advised of the possibility of such loss or damage. Further, Brother shall have no liability to disclose and/or distribute the source cord of the Software to User under any circumstances. In no case shall the above license by Brother to modify, alter, translate or otherwise prepare derivative works of the Software be construed as Brother's implied agreement or undertakings to disclose and/or distribute the source cord of the Software.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..628580f9f166
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Maintainer: Karol Babioch <karol@babioch.de>
+# Inspired by package brother-dcp130c
+
+pkgname='brother-ql1100nwb'
+pkgver=2.1.4r0
+pkgrel=1
+pkgdesc='LPR and CUPS driver for Brother QL-1100NWB label printer'
+url='http://solutions.brother.com/linux/en_us/'
+arch=('i686' 'x86_64')
+license=('custom')
+depends='cups'
+if [ "$CARCH" = 'x86_64' ]; then
+ depends+=('lib32-glibc')
+fi
+install="$pkgname.install"
+source=("http://download.brother.com/welcome/dlfp100576/ql1110nwbpdrv-${pkgver/r/-}.i386.rpm"
+ 'LICENSE')
+sha256sums=('560f71c6c6785e10e1696fee0096fb7ef9592d2dd5beb90fc9cd67200cc921c3'
+ 'cdd1955a9996bc246ba54e84f0a5ccbfdf6623962b668188762389aa79ef9811')
+
+prepare()
+{
+ # do not install in '/usr/local'
+ if [ -d $srcdir/usr/local/Brother ]; then
+ install -d $srcdir/usr/share
+ mv $srcdir/usr/local/Brother/ $srcdir/usr/share/brother
+ rm -rf $srcdir/usr/local
+ sed -i 's|/usr/local/Brother|/usr/share/brother|g' `grep -lr '/usr/local/Brother' ./`
+ fi
+
+ # setup cups directories
+ install -d "$srcdir/usr/share/cups/model"
+ install -d "$srcdir/usr/lib/cups/filter"
+
+ # go to the cupswrapper directory and find the source file from wich to generate a ppd- and wrapper-file
+ cd `find . -type d -name 'cupswrapper'`
+ if [ -f cupswrapper* ]; then
+ _wrapper_source=`ls cupswrapper*`
+ sed -i '/^\/etc\/init.d\/cups/d' $_wrapper_source
+ sed -i '/^sleep/d' $_wrapper_source
+ sed -i '/^echo lpadmin/d' $_wrapper_source
+ sed -i '/^lpadmin/d' $_wrapper_source
+ sed -i 's|/usr|$srcdir/usr|g' $_wrapper_source
+ sed -i 's|/opt|$srcdir/opt|g' $_wrapper_source
+ sed -i 's|/model/Brother|/model|g' $_wrapper_source
+ sed -i 's|lpinfo|echo|g' $_wrapper_source
+ export srcdir=$srcdir
+ ./$_wrapper_source
+ sed -i 's|$srcdir||' $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ sed -i "s|$srcdir||" $srcdir/usr/lib/cups/filter/*lpdwrapper*
+ rm $_wrapper_source
+ fi
+
+ # /etc/printcap is managed by cups
+ rm `find $srcdir -type f -name 'setupPrintcap*'`
+}
+
+package() {
+ cd "$srcdir"
+
+ cp -R usr $pkgdir
+ if [ -d opt ]; then cp -R opt $pkgdir; fi
+
+ install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}
+
diff --git a/brother-ql1100nwb.install b/brother-ql1100nwb.install
new file mode 100644
index 000000000000..8bd666ee98eb
--- /dev/null
+++ b/brother-ql1100nwb.install
@@ -0,0 +1,10 @@
+post_install() {
+ post_upgrade;
+}
+
+post_upgrade() {
+ echo "Restart CUPS to load the new files"
+ echo "You can now register your new printer using the web interface at:"
+ echo " http://localhost:631/"
+}
+