summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD41
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..231bf5edea3a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = browser360
+ pkgdesc = A chromium based web browser from Qihoo 360
+ pkgver = 10.0.2001.0
+ pkgrel = 2
+ url = https://browser.360.cn/se/
+ arch = x86_64
+ license = custom
+ depends = ca-certificates
+ depends = ttf-liberation
+ depends = gconf
+ depends = libappindicator-gtk3
+ depends = gconf
+ depends = gtk2
+ depends = nss
+ depends = libxss
+ depends = lsb-release
+ depends = wget
+ depends = xdg-utils
+ source = ftp://zyiot.top/pub/aur/browser360-cn-stable_10.0.2001.0-2_amd64.deb
+ md5sums = cd23bd055b040cb055907288e4623ddc
+
+pkgname = browser360
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ffee5f03a6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.deb
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac277a381f66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jack Chen <redchenjs@live.com>
+
+pkgname=browser360
+pkgver=10.0.2001.0
+pkgrel=2
+pkgdesc="A chromium based web browser from Qihoo 360"
+arch=('x86_64')
+url="https://browser.360.cn/se/"
+license=('custom')
+depends=(
+ 'ca-certificates'
+ 'ttf-liberation'
+ 'gconf'
+ 'libappindicator-gtk3'
+ 'gconf'
+ 'gtk2'
+ 'nss'
+ 'libxss'
+ 'lsb-release'
+ 'wget'
+ 'xdg-utils'
+)
+source=(
+ 'ftp://zyiot.top/pub/aur/browser360-cn-stable_10.0.2001.0-2_amd64.deb'
+)
+md5sums=(
+ 'cd23bd055b040cb055907288e4623ddc'
+)
+
+package() {
+ cd "${srcdir}"
+ tar -xf data.tar.xz -C "${pkgdir}"
+ # remove cron
+ rm -rf "${pkgdir}"/etc
+ # install icons
+ for i in 16x16 22x22 24x24 32x32 48x48 64x64 128x128 256x256; do
+ install -Dm644 "${pkgdir}"/opt/browser360/product_logo_${i/x*}.png \
+ "${pkgdir}"/usr/share/icons/hicolor/$i/apps/${pkgname}.png
+ done
+ rm "${pkgdir}"/opt/browser360/product_logo_*
+}