summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--install-dir.patch16
3 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4791b8d0c95e..5b69fc80f99d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bsf-git
pkgdesc = A C++ library that aims to provide a unified foundation for the development of real-time graphical applications, whether games, engines or tools
- pkgver = r4677.7c5792cff
+ pkgver = r4710.718f666fc
pkgrel = 1
url = https://www.bsframework.io/
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = bsf-git
source = https://data.banshee3d.com/bsfDocImagesData_Master_2.zip
source = https://data.banshee3d.com/bsfDependencies_Linux_Master_8.zip
sha256sums = SKIP
- sha256sums = ee326f6eb0a97e7b306181a34675b5fadf55ce69bdec1c738600bb9d15908e91
+ sha256sums = 4301910bd0c17e2747c08b27617fe3b4e5f10f70a78ffb29dcef4f23d52b4e16
sha256sums = 871c19f0e652efa2cbdaef34b6960ba9a81378b957cdf3701dc3f8733cb69cd6
sha256sums = 100e91e5ae58dd301adc0d5f31c972237a688f12682e0c0f21e200430728bf27
sha256sums = 3b5e087e200e786ab1a0b79d6f3cd04d4c70fde9337dc8082a13479f477d1025
diff --git a/PKGBUILD b/PKGBUILD
index 93041f1dc674..46f83621d3cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=(bsf-git bsf-git-docs)
pkgbase=bsf-git
_pkgname=bsf
-pkgver=r4677.7c5792cff
+pkgver=r4710.718f666fc
pkgrel=1
epoch=
pkgdesc="A C++ library that aims to provide a unified foundation for the development of real-time graphical applications, whether games, engines or tools"
@@ -93,7 +93,7 @@ package_bsf-git-docs() {
}
sha256sums=('SKIP'
- 'ee326f6eb0a97e7b306181a34675b5fadf55ce69bdec1c738600bb9d15908e91'
+ '4301910bd0c17e2747c08b27617fe3b4e5f10f70a78ffb29dcef4f23d52b4e16'
'871c19f0e652efa2cbdaef34b6960ba9a81378b957cdf3701dc3f8733cb69cd6'
'100e91e5ae58dd301adc0d5f31c972237a688f12682e0c0f21e200430728bf27'
'3b5e087e200e786ab1a0b79d6f3cd04d4c70fde9337dc8082a13479f477d1025'
diff --git a/install-dir.patch b/install-dir.patch
index 545a6b3a67e2..705002dd37ad 100644
--- a/install-dir.patch
+++ b/install-dir.patch
@@ -1,16 +1,16 @@
diff --git a/Source/CMake/BsEngineConfig.h.in b/Source/CMake/BsEngineConfig.h.in
-index 01a7db342..ff99fdedd 100644
+index 301aaf73f..db89006bf 100644
--- a/Source/CMake/BsEngineConfig.h.in
+++ b/Source/CMake/BsEngineConfig.h.in
-@@ -6,18 +6,9 @@
- #define BS_PHYSICS_MODULE "@PHYSICS_MODULE_LIB@"
+@@ -7,18 +7,9 @@
+ #define BS_SCRIPTING_ENABLED @BS_SCRIPTING_ENABLED@
- /** Path to the framework root when files haven't been packaged yet (e.g. running from debugger). */
+ /** Path to the framework source directory. */
-static constexpr const char* RAW_APP_ROOT = "@APP_ROOT_DIR@/";
+static constexpr const char* RAW_APP_ROOT = "@CMAKE_INSTALL_PREFIX@/share/bsf/";
- /** Secondary search path to use when looking for built-in assets (after the RAW_APP_ROOT). */
- static constexpr const char* SECONDARY_APP_ROOT = "@SECONDARY_APP_ROOT_DIR@/";
+ /** Path to the framework build directory. */
+ static constexpr const char* BUILD_APP_ROOT = "@PROJECT_BINARY_DIR@/";
-/** Path to the binaries when files haven't been packaged yet (e.g. running from debugger). */
-#if BS_CONFIG == BS_CONFIG_DEBUG
@@ -24,10 +24,10 @@ index 01a7db342..ff99fdedd 100644
-#endif
+static constexpr const char* BINARIES_PATH = "@CMAKE_INSTALL_PREFIX@/lib/";
diff --git a/Source/CMakeLists.txt b/Source/CMakeLists.txt
-index 02ba71c5a..ebaac189c 100644
+index a35dc9bea..87831df61 100644
--- a/Source/CMakeLists.txt
+++ b/Source/CMakeLists.txt
-@@ -195,8 +195,8 @@ check_and_update_builtin_assets(bsfCompiled ${BSF_SOURCE_DIR}/../Data Data ${COM
+@@ -220,8 +220,8 @@ endif()
## Install
install(