summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--bsnes9
3 files changed, 11 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5bf9f448f1e4..b00aacaf85cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bsnes-plus-git
pkgdesc = debug-oriented fork of bsnes v073
- pkgver = 0.73r127.a3d2120
+ pkgver = 0.73r163.a55717a
pkgrel = 1
url = https://github.com/devinacker/bsnes-plus
arch = i686
@@ -13,14 +13,14 @@ pkgbase = bsnes-plus-git
depends = openal
depends = qt4
depends = sdl
- depends = xdialog
+ depends = zenity
provides = bsnes-plus
conflicts = bsnes-plus
conflicts = bsnes-classic
source = git+https://github.com/devinacker/bsnes-plus.git
source = bsnes
sha1sums = SKIP
- sha1sums = 8ee7fedf0a2aa081f57044eeaf52ba53806f7af6
+ sha1sums = 102a1295bfa6389a989f65d3037537f7d537e68b
pkgname = bsnes-plus-git
diff --git a/PKGBUILD b/PKGBUILD
index 7761d76086ed..7baa411953b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
-# Maintainer: Duck Hunt <vaporeon@tfwno.gf>
+# Maintainer: Vaporeon <vaporeon@tfwno.gf>
pkgname=bsnes-plus-git
-pkgver=0.73r127.a3d2120
+pkgver=0.73r163.a55717a
pkgrel=1
pkgdesc='debug-oriented fork of bsnes v073'
arch=('i686' 'x86_64')
url='https://github.com/devinacker/bsnes-plus'
license=('GPL3')
-depends=('libao' 'libpulse' 'openal' 'qt4' 'sdl' 'xdialog')
+depends=('libao' 'libpulse' 'openal' 'qt4' 'sdl' 'zenity')
makedepends=('mesa' 'git')
source=("git+${url}.git"
'bsnes')
sha1sums=('SKIP'
- '8ee7fedf0a2aa081f57044eeaf52ba53806f7af6')
+ '102a1295bfa6389a989f65d3037537f7d537e68b')
conflicts=('bsnes-plus' 'bsnes-classic')
provides=('bsnes-plus')
@@ -51,4 +51,4 @@ package() {
for p in {accuracy,compatibility}; do
install -m 755 bsnes/out/bsnes-$p "${pkgdir}"/usr/bin/
done
-} \ No newline at end of file
+}
diff --git a/bsnes b/bsnes
index 226f9d04c5df..1d5a0d51438d 100644
--- a/bsnes
+++ b/bsnes
@@ -1,9 +1,6 @@
#!/bin/sh
-# Check for profiles and prompt user with a GUI
-[ -e /usr/bin/bsnes-accuracy ] && tag1=accuracy
-[ -e /usr/bin/bsnes-compatibility ] && tag2=compatibility
-profile="$(Xdialog --stdout --no-tags --title "bsnes-plus" --radiolist "Choose a profile" 0 0 "$tag1" "Accuracy" off "$tag2" "Compatibility" off)"
-
+# Prompt for profile
+profile="$(zenity --list --radiolist --title 'Please select a profile' --column '' --column '' FALSE 'accuracy' TRUE 'compatibility')"
# Launch selected profile
-exec bsnes-$profile "$@" \ No newline at end of file
+[[ -n $profile ]] && exec bsnes-$profile "$@"