summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
-rw-r--r--btdex.desktop4
-rw-r--r--[-rwxr-xr-x]btdex.sh2
5 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8d40b4206c6..55a61067ceb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = btdex
pkgdesc = Decentralized exchange system running on the Burst blockchain
pkgver = 0.1.21
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/btdex/btdex
install = btdex.install
arch = x86_64
@@ -12,13 +12,13 @@ pkgbase = btdex
conflicts = btdex-git
options = !strip
source = https://github.com/btdex/btdex/releases/download/v0.1.21/btdex-all-v0.1.21.jar
- source = https://github.com/btdex/btdex/raw/master/src/main/resources/icon.png
- source = btdex.sh
- source = btdex.desktop
+ source = https://raw.githubusercontent.com/btdex/btdex/v0.1.21/dist/btdex.ico
+ source = https://raw.githubusercontent.com/btdex/btdex/v0.1.21/dist/btdex.sh
+ source = https://raw.githubusercontent.com/btdex/btdex/v0.1.21/dist/btdex.desktop
sha256sums = e710dc7f77917d8a3e10172acb619529dff5c319e5ac374fc60c586a4fec8be5
- sha256sums = f17dc59e7d436b4e5e577283d116599d998a88132d45d7c3e769aa21543cd9a9
- sha256sums = 162e5c9fad5d5a5e5a59192a64ce6d1a5bf189465eeae4130332b3838f4d9c11
- sha256sums = d6ab59c4046cf2c3b8898c7635151e7bea726f0a914f9d353134982e56a1295f
+ sha256sums = 18e0fa60623d1886743f8dab10350b6ab5bba9eb0bb1eef7be6991369a4af3f2
+ sha256sums = 3c1830a574257a35e4d4e1a242f786b98fb3fa0d3c7db1418d4b69d4df881533
+ sha256sums = fa8e5f6561192d1f2554365a7f49c36ac368ae00413f489c0873a801c11e6219
pkgname = btdex
diff --git a/.gitignore b/.gitignore
index 272b1e18df9a..64e6d61ae2a0 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,4 @@
!PKGBUILD
!.SRCINFO
!*.install
-!.gitignore
-!btdex.desktop
-!btdex.sh \ No newline at end of file
+!.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index dd7217a08be3..6b922c191755 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=btdex
pkgver=0.1.21
-pkgrel=1
+pkgrel=2
pkgdesc='Decentralized exchange system running on the Burst blockchain'
arch=(x86_64)
url='https://github.com/btdex/btdex'
@@ -14,24 +14,24 @@ conflicts=(btdex-git)
provides=(btdex-git)
install=btdex.install
source=(https://github.com/btdex/btdex/releases/download/v$pkgver/btdex-all-v$pkgver.jar
- https://github.com/btdex/btdex/raw/master/src/main/resources/icon.png
- btdex.sh
- btdex.desktop)
+ https://raw.githubusercontent.com/btdex/btdex/v$pkgver/dist/btdex.ico
+ https://raw.githubusercontent.com/btdex/btdex/v$pkgver/dist/btdex.sh
+ https://raw.githubusercontent.com/btdex/btdex/v$pkgver/dist/btdex.desktop)
sha256sums=('e710dc7f77917d8a3e10172acb619529dff5c319e5ac374fc60c586a4fec8be5'
- 'f17dc59e7d436b4e5e577283d116599d998a88132d45d7c3e769aa21543cd9a9'
- '162e5c9fad5d5a5e5a59192a64ce6d1a5bf189465eeae4130332b3838f4d9c11'
- 'd6ab59c4046cf2c3b8898c7635151e7bea726f0a914f9d353134982e56a1295f')
+ '18e0fa60623d1886743f8dab10350b6ab5bba9eb0bb1eef7be6991369a4af3f2'
+ '3c1830a574257a35e4d4e1a242f786b98fb3fa0d3c7db1418d4b69d4df881533'
+ 'fa8e5f6561192d1f2554365a7f49c36ac368ae00413f489c0873a801c11e6219')
package() {
cd $srcdir
install -d $pkgdir/opt/$pkgname
- install -Dm644 btdex-all-v$pkgver.jar $pkgdir/opt/$pkgname/btdex.jar
+ install -Dm644 btdex-all-v$pkgver.jar $pkgdir/opt/$pkgname/btdex-all.jar
install -Dm755 btdex.sh $pkgdir/opt/$pkgname/btdex.sh
install -d $pkgdir/usr/bin
ln -sf /opt/$pkgname/btdex.sh $pkgdir/usr/bin/btdex
# Menu entry
install -Dm644 $pkgname.desktop -t $pkgdir/usr/share/applications
- install -Dm644 icon.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ install -Dm644 btdex.ico $pkgdir/usr/share/pixmaps/$pkgname.ico
}
diff --git a/btdex.desktop b/btdex.desktop
index 3eb4dc1a1131..690a700b0561 100644
--- a/btdex.desktop
+++ b/btdex.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Type=Application
Name=BTDEX
-Comment=Decentralized exchange system running on the Burstcoin blockchain
-Icon=/usr/share/pixmaps/btdex.png
+Comment=A decentralized exchange system running on the Burst blockchain.
+Icon=btdex
Exec=/opt/btdex/btdex.sh
Categories=Network;
diff --git a/btdex.sh b/btdex.sh
index b825603e0960..755f785a51ed 100755..100644
--- a/btdex.sh
+++ b/btdex.sh
@@ -4,4 +4,4 @@ CONFIG_DIR="$HOME/.config/btdex"
mkdir -p $CONFIG_DIR
-java -jar /opt/btdex/btdex.jar -f "$CONFIG_DIR/config.properties"
+java -jar /opt/btdex/btdex-all.jar -f "$CONFIG_DIR/config.properties"