summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--subprocess.check_output.patch24
3 files changed, 9 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8bb289f01d72..fefad06f6a23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,14 @@
pkgbase = btrfs-compress
pkgdesc = btrfs tool that makes it possible to change +c flags recursively on existing files
- pkgver = 20190221.r11
- pkgrel = 2
+ pkgver = 20190221.r12
+ pkgrel = 1
url = https://github.com/benapetr/compress
arch = i686
arch = x86_64
license = BSD
+ makedepends = git
depends = python
- source = git+https://github.com/benapetr/compress.git#commit=5b5afb8cdfa0fbe94a1535dcd682816fc3672e1b
- source = subprocess.check_output.patch
+ source = git+https://github.com/benapetr/compress.git#commit=394be8f2a44b8587c7190decf4d758e15dfed9d7
b2sums = SKIP
- b2sums = 578ad8a209d7f80eacf006de338e5a9235f7b3d9f4dced084046bc8cd45feeaf39131fad86d93ed95310baa4500ae736411ce39916fb2ebe6222a4a384de2d45
pkgname = btrfs-compress
-
diff --git a/PKGBUILD b/PKGBUILD
index e3725db05fe2..62e366d51aad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,16 @@
pkgname=btrfs-compress
# compress is too generic a name!!! Also the script is unmaintained upstream but still works.
_pkgname=compress
-pkgver=20190221.r11
-pkgrel=2
+pkgver=20190221.r12
+pkgrel=1
pkgdesc="btrfs tool that makes it possible to change +c flags recursively on existing files"
arch=('i686' 'x86_64')
url="https://github.com/benapetr/compress"
license=('BSD')
depends=('python')
-source=("git+https://github.com/benapetr/$_pkgname.git#commit=5b5afb8cdfa0fbe94a1535dcd682816fc3672e1b"
- 'subprocess.check_output.patch')
-b2sums=('SKIP'
- '578ad8a209d7f80eacf006de338e5a9235f7b3d9f4dced084046bc8cd45feeaf39131fad86d93ed95310baa4500ae736411ce39916fb2ebe6222a4a384de2d45')
+makedepends=('git')
+source=("git+https://github.com/benapetr/$_pkgname.git#commit=394be8f2a44b8587c7190decf4d758e15dfed9d7")
+b2sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -22,11 +21,6 @@ pkgver() {
"$(git rev-list --count HEAD)"
}
-prepare() {
- cd "$_pkgname"
- patch -p1 < ../subprocess.check_output.patch
-}
-
build() {
cd "$_pkgname"
sed -i -e 's!\(/usr/bin/\)env !&!' src/$_pkgname
diff --git a/subprocess.check_output.patch b/subprocess.check_output.patch
deleted file mode 100644
index c5d6c1168feb..000000000000
--- a/subprocess.check_output.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/README.md b/README.md
-index 3500363..24a663b 100644
---- a/README.md
-+++ b/README.md
-@@ -16,3 +16,6 @@ compress -vr some_folder
-
- # installation
- sudo cp src/compress /usr/local/bin
-+
-+# known issues
-+compress doesn't check if files that are being compressed are open or not, it's not recommended to use compress on files that are open by other processes, since compress will unlink them, resulting in open file descriptors to deleted files.
-diff --git a/src/compress b/src/compress
-index 9fe00ae..9473c7e 100755
---- a/src/compress
-+++ b/src/compress
-@@ -52,7 +52,7 @@ def test_compress(path):
- result = subprocess.check_output(["lsattr", path]).strip()
- if (result == ''):
- raise Exception('lsattr returned nothing')
-- result = result[:result.index(" ")]
-+ result = result[:result.index(b' ')]
- for f in result:
- if (f == 'c'):
- return True