summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..679fdd820ea4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = btrfs-du
+ pkgdesc = Easily print BTRFS subvolume/snapshot disk usage
+ pkgver = 0.0.6
+ pkgrel = 1
+ url = https://github.com/nachoparker/btrfs-du
+ arch = any
+ license = GPL3
+ depends = btrfs-progs
+ source = https://github.com/nachoparker/btrfs-du/archive/v0.0.6.tar.gz
+ md5sums = 5b61c3f157e2a4aec6e8ce16fdd67e68
+
+pkgname = btrfs-du
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a768e5b85949
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Chris Trotman <chris@trotman.io>
+pkgname=btrfs-du
+pkgver=0.0.6
+pkgrel=1
+pkgdesc="Easily print BTRFS subvolume/snapshot disk usage"
+arch=('any')
+url="https://github.com/nachoparker/btrfs-du"
+license=('GPL3')
+depends=("btrfs-progs")
+source=("https://github.com/nachoparker/btrfs-du/archive/v$pkgver.tar.gz")
+md5sums=("5b61c3f157e2a4aec6e8ce16fdd67e68")
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr/bin
+ cp btrfs-du $pkgdir/usr/bin/
+}