summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD39
-rw-r--r--bubblebuddy.desktop8
-rw-r--r--bubblebuddy.sh4
5 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52cb2acba9a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = bubblebuddy-git
+ pkgdesc = Bubble Hockey program intended for Raspberry Pi
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://gitlab.com/neilsimp1/bubblebuddy
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = nodejs
+ makedepends = npm
+ depends = electron
+ source = git+https://gitlab.com/neilsimp1/bubblebuddy.git
+ source = bubblebuddy.desktop
+ source = bubblebuddy.sh
+ sha256sums = SKIP
+ sha256sums = 489548c045d2149a8ebb87d424909c005c0174e3bd91af8aa3ba22e16bd13292
+ sha256sums = cc675f85f1e8f72f1376864f439b07d124a7a40d5bc2ce9c5a03e3430c82b59e
+
+pkgname = bubblebuddy-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..21b4505e601d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+bubblebuddy/
+pkg/
+src/
+*.tar.gz
+*.tar.xz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..539463f09d2d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Neil Simpson <neilsimp1@gmail.com>
+
+pkgname=bubblebuddy-git
+_pkgname=bubblebuddy
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Bubble Hockey program intended for Raspberry Pi"
+arch=("any")
+url="https://gitlab.com/neilsimp1/bubblebuddy"
+license=("GPL3")
+depends=("electron")
+makedepends=("git" "nodejs" "npm")
+source=("git+https://gitlab.com/neilsimp1/bubblebuddy.git"
+ "bubblebuddy.desktop"
+ "bubblebuddy.sh")
+sha256sums=("SKIP"
+ "489548c045d2149a8ebb87d424909c005c0174e3bd91af8aa3ba22e16bd13292"
+ "cc675f85f1e8f72f1376864f439b07d124a7a40d5bc2ce9c5a03e3430c82b59e")
+
+build() {
+ cd "$srcdir/$_pkgname"
+
+ npm install --cache "${srcdir}/npm-cache"
+ npm run build
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm 644 bubblebuddy.desktop "$pkgdir"/usr/share/applications/bubblebuddy.desktop
+ install -Dm 755 bubblebuddy.sh "$pkgdir"/usr/bin/bubblebuddy
+
+ cd "$srcdir/$_pkgname"
+ install -Dm 644 COPYING -t "$pkgdir"/usr/share/licenses/$_pkgname
+ install -Dm 644 icon.png "$pkgdir"/usr/share/icons/bubblebuddy.png
+
+ cd "$srcdir/$_pkgname/dist_electron"
+ mkdir "$pkgdir"/usr/share/$_pkgname
+ cp -R "linux-unpacked"/* "$pkgdir"/usr/share/$_pkgname
+}
diff --git a/bubblebuddy.desktop b/bubblebuddy.desktop
new file mode 100644
index 000000000000..50ab919c18d8
--- /dev/null
+++ b/bubblebuddy.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=BubbleBuddy
+Description=BubbleBuddy is a Bubble Hockey game intended for Raspberry Pi
+Exec=bubblebuddy
+Terminal=false
+Type=Application
+Icon=/usr/share/icons/bubblebuddy.png
+Categories=Office;Utilities;
diff --git a/bubblebuddy.sh b/bubblebuddy.sh
new file mode 100644
index 000000000000..04214f98a981
--- /dev/null
+++ b/bubblebuddy.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/share/bubblebuddy
+./bubblebuddy