summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD49
-rw-r--r--disable-analytics.patch11
3 files changed, 17 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a896928f3f78..54087fff59be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,14 @@
-# Generated by mksrcinfo v8
-# Sat Dec 1 23:00:55 UTC 2018
pkgbase = buckaroo
pkgdesc = A C++ package manager
- pkgver = 1.5.0
+ pkgver = 2.2.0
pkgrel = 1
url = https://github.com/LoopPerfect/buckaroo
- arch = any
+ arch = x86_64
license = MIT
- depends = java-runtime
depends = buck
- source = https://github.com/LoopPerfect/buckaroo/archive/v1.5.0.tar.gz
- source = disable-analytics.patch
- sha256sums = e8c2bc83b967b49840c370a61c862ef3c63146ef4b4e6de901f9d6abb91025b0
- sha256sums = 9b8eb3b92afb718b151859379d409b5329bd02e7363cc298c444fd6db35b4478
+ options = !strip
+ source = https://github.com/LoopPerfect/buckaroo/releases/download/v2.2.0/buckaroo-linux
+ sha256sums = 23f9a4145a3e51f1205a4b265374c548fc4a4e9156e5121285f5c5bdb4d3228c
pkgname = buckaroo
diff --git a/PKGBUILD b/PKGBUILD
index 6e28084e59a1..9e717ef7db15 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,47 +1,22 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=buckaroo
-pkgver=1.5.0
+pkgver=2.2.0
pkgrel=1
pkgdesc="A C++ package manager"
-arch=('any')
+arch=('x86_64')
url="https://github.com/LoopPerfect/buckaroo"
license=('MIT')
-depends=('java-runtime' 'buck')
-makedepends=('')
+depends=('buck')
+options=(!strip)
-source=("https://github.com/LoopPerfect/${pkgname}/archive/v${pkgver}.tar.gz"
- disable-analytics.patch)
-sha256sums=('e8c2bc83b967b49840c370a61c862ef3c63146ef4b4e6de901f9d6abb91025b0'
- '9b8eb3b92afb718b151859379d409b5329bd02e7363cc298c444fd6db35b4478')
-
-prepare() {
- # Make telemetry an opt-in feature by omitting the "analytics"
- # property in the default configuration.
- #
- # If you want to enable it to support the development, add the
- # following property to "~/.buckaroo/buckaroo.json" (this config
- # will be created automatically after the first run):
- #
- # "analytics": "https://analytics.buckaroo.pm"
- #
- # For more details, see the documentation:
- # https://buckaroo.readthedocs.io/en/latest/installation.html#analytics
- patch -Np1 -i "${srcdir}/disable-analytics.patch"
-}
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- buck build :buckaroo-cli
-}
+source=("https://github.com/LoopPerfect/buckaroo/releases/download/v${pkgver}/buckaroo-linux")
+sha256sums=('23f9a4145a3e51f1205a4b265374c548fc4a4e9156e5121285f5c5bdb4d3228c')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
-
- install -Dm644 buck-out/gen/buckaroo-cli.jar ${pkgdir}/usr/lib/${pkgname}/buckaroo-cli.jar
-
- mkdir -p ${pkgdir}/usr/bin
- printf "#!/bin/sh\njava -jar /usr/lib/%s/buckaroo-cli.jar \"\$@\"\n" ${pkgname} > "${pkgdir}/usr/bin/buckaroo"
- chmod 755 "${pkgdir}/usr/bin/buckaroo"
+ # Make telemetry an opt-in feature
+ mkdir -p "${pkgdir}/etc/profile.d"
+ echo "export BUCKAROO_TELEMETRY_OPT_OUT=1" > "${pkgdir}/etc/profile.d/buckaroo-telemetry-opt-out.sh"
- install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}
+ # Install the binary
+ install -Dm755 buckaroo-linux "${pkgdir}/usr/bin/buckaroo"
+} \ No newline at end of file
diff --git a/disable-analytics.patch b/disable-analytics.patch
deleted file mode 100644
index cbf8b41d3016..000000000000
--- a/disable-analytics.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ura src/buckaroo-1.5.0/src/main/resources/com.loopperfect.buckaroo/DefaultConfig.txt src.new/buckaroo-1.5.0/src/main/resources/com.loopperfect.buckaroo/DefaultConfig.txt
---- src/buckaroo-1.5.0/src/main/resources/com.loopperfect.buckaroo/DefaultConfig.txt 2018-11-09 16:02:51.000000000 +0100
-+++ src.new/buckaroo-1.5.0/src/main/resources/com.loopperfect.buckaroo/DefaultConfig.txt 2018-12-01 20:41:44.525516188 +0100
-@@ -4,6 +4,5 @@
- "name": "buckaroo-recipes",
- "url": "https://github.com/LoopPerfect/buckaroo-recipes.git"
- }
-- ],
-- "analytics": "https://analytics.buckaroo.pm"
-+ ]
- }