summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD54
3 files changed, 73 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 286d3326f145..e307766da3be 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
pkgbase = budgie-indicator-applet
pkgdesc = Application Indicator Applet for the budgie-desktop
- pkgver = 0.6.2
+ pkgver = 0.7.2.r1.g6ff6208
pkgrel = 1
url = https://github.com/UbuntuBudgie/budgie-indicator-applet
arch = i686
arch = x86_64
- license = LGPL3
- makedepends = gobject-introspection
- makedepends = gtk3
- makedepends = intltool
- makedepends = libtool
+ license = GPL-3.0-only
+ makedepends = git
+ depends = atk
+ depends = ayatana-ido
depends = budgie-desktop
- depends = ido
- depends = libindicator-gtk3
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = glibc
+ depends = gtk3
+ depends = libayatana-indicator
depends = libpeas
- source = https://github.com/UbuntuBudgie/budgie-indicator-applet/archive/v0.6.2.tar.gz
- sha512sums = 7faaad7418d4df7eaef675c281c1fc09f06eb979f6e3662e9e757628ea7d94c24264d15a4c9f2b70cf78a259b11881903c3e43a56150b800307e25decdd95b99
+ source = git+https://github.com/UbuntuBudgie/budgie-indicator-applet.git#commit=6ff6208c28ebf97c80b2534511e48e95fef3d5b8
+ b2sums = SKIP
pkgname = budgie-indicator-applet
-
diff --git a/.gitignore b/.gitignore
index 924dfb95c209..058ba2318df1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,18 @@
-pkg/
-src/
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+*.tar
*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+
+*/
+*.orig
+*.bak
+*.backup
+*.kate-swp
+.directory
diff --git a/PKGBUILD b/PKGBUILD
index 5631e216d55b..d414b3a98be0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,61 @@
-# Maintainer:
+# Contributor: Marcell Meszaros < marcell.meszaros AT runbox.eu >
# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Kaizhao Zhang <zhangkaizhao@gmail.com>
pkgname=budgie-indicator-applet
-pkgver=0.6.2
+pkgver=0.7.2.r1.g6ff6208
+_commit=6ff6208c28ebf97c80b2534511e48e95fef3d5b8
pkgrel=1
pkgdesc="Application Indicator Applet for the budgie-desktop"
url='https://github.com/UbuntuBudgie/budgie-indicator-applet'
arch=('i686' 'x86_64')
-license=('LGPL3')
-depends=('budgie-desktop' 'ido' 'libindicator-gtk3' 'libpeas')
-makedepends=('gobject-introspection' 'gtk3' 'intltool' 'libtool')
+license=('GPL-3.0-only')
+depends=(
+ 'atk'
+ 'ayatana-ido'
+ 'budgie-desktop'
+ 'gdk-pixbuf2'
+ 'glib2'
+ 'glibc'
+ 'gtk3'
+ 'libayatana-indicator'
+ 'libpeas'
+)
+makedepends=(
+ 'git'
+)
+source=("git+${url}.git#commit=${_commit}")
+b2sums=('SKIP')
-source=("https://github.com/UbuntuBudgie/budgie-indicator-applet/archive/v${pkgver}.tar.gz")
-sha512sums=('7faaad7418d4df7eaef675c281c1fc09f06eb979f6e3662e9e757628ea7d94c24264d15a4c9f2b70cf78a259b11881903c3e43a56150b800307e25decdd95b99')
+prepare() {
+ cd "${srcdir}/${pkgname}"
+
+ echo "Adding LDFLAGS vaues to CLFLAGS to respect LTO, relro, as-needed etc. configs."
+ export CFLAGS+=" ${LDFLAGS}"
+
+ ./autogen.sh \
+ --libdir=/usr/lib \
+ --prefix=/usr \
+ --sharedstatedir=/var \
+ --sharedstatedir=/var/lib \
+ --sysconfdir=/etc \
+ --with-ayatana-indicators
+
+ echo "Adding LTO and '--as-needed' params to libtool."
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+}
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --long --tags| sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- ./autogen.sh --prefix=/usr
+ cd "${srcdir}/${pkgname}"
make
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
+ cd "${srcdir}/${pkgname}"
make DESTDIR="${pkgdir}" install
}