summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD18
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dbadfaf9f29c..d7c99f1469f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = buf
pkgdesc = A new way of working with Protocol Buffers
- pkgver = 1.0.0rc1
+ pkgver = 1.0.0rc3
pkgrel = 1
url = https://buf.build
arch = any
license = Apache
makedepends = go
- source = https://github.com/bufbuild/buf/archive/v1.0.0-rc1.tar.gz
- sha256sums = 0d0ec20014918ac183c705183b20804e06692bbed6338608674d4591738f32bf
+ source = https://github.com/bufbuild/buf/archive/v1.0.0-rc3.tar.gz
+ sha256sums = 0f438e02634e97352047a6dc6f77cbf6f113842040f78334e4b3bb5bf6603cf7
pkgname = buf
diff --git a/PKGBUILD b/PKGBUILD
index bbcf434ddbc3..c7473f214158 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,28 @@
# Maintainer: Johan Brandhorst <jbrandhorst@buf.build>
# Contributor: Alexander Menzhinsky <amenzhinsky@gmail.com>
pkgname=buf
-pkgver=1.0.0rc1
+pkgver=1.0.0rc3
pkgrel=1
pkgdesc="A new way of working with Protocol Buffers"
arch=("any")
url="https://buf.build"
license=('Apache')
makedepends=('go')
-source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc1.tar.gz")
+source=("https://github.com/bufbuild/buf/archive/v1.0.0-rc3.tar.gz")
build() {
- cd ${pkgname}-1.0.0-rc1
+ cd ${pkgname}-1.0.0-rc3
go build -trimpath -buildmode=pie -mod=readonly -modcacherw -o . ./cmd/{buf,protoc-gen-buf-lint,protoc-gen-buf-breaking}
./buf bash-completion >completion.bash
./buf zsh-completion >completion.zsh
}
package() {
- install -Dm755 "${pkgname}-1.0.0-rc1/buf" "${pkgdir}/usr/bin/buf"
- install -Dm755 "${pkgname}-1.0.0-rc1/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
- install -Dm755 "${pkgname}-1.0.0-rc1/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
- install -Dm644 "${pkgname}-1.0.0-rc1/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
- install -Dm644 "${pkgname}-1.0.0-rc1/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
+ install -Dm755 "${pkgname}-1.0.0-rc3/buf" "${pkgdir}/usr/bin/buf"
+ install -Dm755 "${pkgname}-1.0.0-rc3/protoc-gen-buf-lint" "${pkgdir}/usr/bin/protoc-gen-buf-lint"
+ install -Dm755 "${pkgname}-1.0.0-rc3/protoc-gen-buf-breaking" "${pkgdir}/usr/bin/protoc-gen-buf-breaking"
+ install -Dm644 "${pkgname}-1.0.0-rc3/completion.bash" "${pkgdir}/etc/bash_completion.d/buf"
+ install -Dm644 "${pkgname}-1.0.0-rc3/completion.zsh" "${pkgdir}/usr/share/zsh/site-functions/_buf"
}
-sha256sums=('0d0ec20014918ac183c705183b20804e06692bbed6338608674d4591738f32bf')
+sha256sums=('0f438e02634e97352047a6dc6f77cbf6f113842040f78334e4b3bb5bf6603cf7')