summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD18
3 files changed, 23 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91efecbabe69..28b2cd38f77d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,20 @@
pkgbase = buffalo-bin
pkgdesc = A Go web development eco-system, designed to make your project easier.
- pkgver = 0.16.8
+ pkgver = 0.16.9
pkgrel = 2
url = https://github.com/gobuffalo/buffalo/
arch = x86_64
license = MIT
makedepends = tar
- conflicts = buffalo
- source = buffalo-bin-0.16.8.tar.gz::https://github.com/gobuffalo/buffalo/releases/download/v0.16.8/buffalo_0.16.8_Linux_x86_64.tar.gz
- sha256sums = 77ade8c844d19d40bdece33366902df1b8c9cdde74632d7062621cc81d1a6094
+ depends = go>=1.13
+ optdepends = nodejs>=8: frontend
+ optdepends = npm: asset pipeline
+ optdepends = yarn: frontend dependency management
+ optdepends = gcc: for building sqlite3 support
+ optdepends = git: for VCS support
+ conflicts = buffalo-git
+ source = buffalo-bin-0.16.9.tar.gz::https://github.com/gobuffalo/buffalo/releases/download/v0.16.9/buffalo_0.16.9_Linux_x86_64.tar.gz
+ sha256sums = f716b4d818bdb6e5af1a0071a9b99ee2db093908bd45d4bfe02077be433c35f6
pkgname = buffalo-bin
diff --git a/.gitignore b/.gitignore
index dafa321eb121..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1 +1 @@
-/*.tar.*
+*
diff --git a/PKGBUILD b/PKGBUILD
index 8a7b96b8773b..6561f8d7f6d9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
-# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
+# Maintainer: theguy147 <yakamoz147 (at) protonmail (dot) com>
# Contributor: Marco Steiger <marco (at) steiger (dot) online>
pkgname=buffalo-bin
-pkgver=0.16.8
+pkgver=0.16.9
pkgrel=2
pkgdesc='A Go web development eco-system, designed to make your project easier.'
-url="https://github.com/gobuffalo/buffalo/"
arch=('x86_64')
+url="https://github.com/gobuffalo/buffalo/"
license=('MIT')
makedepends=('tar')
-conflicts=('buffalo')
+depends=('go>=1.13')
+optdepends=('nodejs>=8: frontend'
+ 'npm: asset pipeline'
+ 'yarn: frontend dependency management'
+ 'gcc: for building sqlite3 support'
+ 'git: for VCS support')
+conflicts=('buffalo-git')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/gobuffalo/buffalo/releases/download/v${pkgver}/buffalo_${pkgver}_Linux_x86_64.tar.gz")
-sha256sums=('77ade8c844d19d40bdece33366902df1b8c9cdde74632d7062621cc81d1a6094')
+sha256sums=('f716b4d818bdb6e5af1a0071a9b99ee2db093908bd45d4bfe02077be433c35f6')
package() {
- install -Dm755 "${srcdir}/buffalo" "${pkgdir}/usr/bin/buffalo"
+ install -Dm755 "${srcdir}/buffalo" "${pkgdir}/usr/bin/buffalo"
}