summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--build.patch11
3 files changed, 6 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f5e812d539be..7631d9fd850c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = build2
pkgdesc = build2 build system
- pkgver = 0.15.0
+ pkgver = 0.16.0
pkgrel = 1
url = https://build2.org/
arch = i686
@@ -10,9 +10,7 @@ pkgbase = build2
depends = sqlite3
depends = pkgconf
options = !ccache
- source = https://download.build2.org/0.15.0/build2-toolchain-0.15.0.tar.xz
- source = build.patch
- sha256sums = 5152f679daeb9627f9710c60ef88de1591c02097146268be2f5aea929d2837c4
- sha256sums = fa551d0fa42c622caa147acc42944ea709d6147ce91847bb9bc86be321b09fdf
+ source = https://download.build2.org/0.16.0/build2-toolchain-0.16.0.tar.xz
+ sha256sums = 23793f682a17b1d95c80bbd849244735ed59a3e27361529aa4865d2776ff8adc
pkgname = build2
diff --git a/PKGBUILD b/PKGBUILD
index f6fbe5fe412f..36e0a0d08465 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Filipe Verri <filipeverri@gmail.com>
pkgname=build2
-pkgver=0.15.0
+pkgver=0.16.0
pkgrel=1
pkgdesc="build2 build system"
arch=(i686 x86_64)
@@ -12,17 +12,13 @@ license=('MIT')
options=('!ccache')
makedepends=('wget')
depends=('sqlite3' 'pkgconf')
-source=("https://download.build2.org/${pkgver}/build2-toolchain-${pkgver}.tar.xz"
- "build.patch")
+source=("https://download.build2.org/${pkgver}/build2-toolchain-${pkgver}.tar.xz")
-sha256sums=('5152f679daeb9627f9710c60ef88de1591c02097146268be2f5aea929d2837c4'
- 'fa551d0fa42c622caa147acc42944ea709d6147ce91847bb9bc86be321b09fdf')
+sha256sums=('23793f682a17b1d95c80bbd849244735ed59a3e27361529aa4865d2776ff8adc')
build() {
cd ${srcdir}/build2-toolchain-${pkgver}
- patch -p0 < ${srcdir}/build.patch
-
mkdir -p ${srcdir}/build/usr
./build.sh --trust yes --local --system libsqlite3,libpkgconfig --install-dir ${srcdir}/build/usr ${CXX:-g++} $CXXFLAGS
diff --git a/build.patch b/build.patch
deleted file mode 100644
index 0163ddf8f1c7..000000000000
--- a/build.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- build.sh.orig 2022-07-28 15:16:00.000000000 +0200
-+++ build.sh 2022-08-02 22:15:53.761448625 +0200
-@@ -597,7 +597,7 @@
- run build2/build2/b-boot $verbose configure \
- config.config.hermetic=true \
- config.cxx="$cxx" \
--config.cc.coptions="$*" \
-+config.cc.coptions="-I/usr/include/pkgconf $*" \
- config.bin.lib=shared \
- config.bin.rpath="$conf_rpath" \
- config.install.root="$idir" \