summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 17 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5605357a23e..ef889a765e76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = buildstream
pkgdesc = Framework for modelling build pipelines in a declarative YAML format
pkgver = 1.1.3
- pkgrel = 1
+ pkgrel = 2
url = https://wiki.gnome.org/Projects/BuildStream/
arch = any
license = LGPL
@@ -15,6 +15,11 @@ pkgbase = buildstream
depends = python-pluginbase
depends = python-psutil
depends = python-ruamel-yaml
+ depends = bubblewrap
+ depends = bzr
+ depends = git
+ depends = lzip
+ optdepends = python-arpy
source = https://download.gnome.org/sources/BuildStream/1.1/BuildStream-1.1.3.tar.xz
sha256sums = 3fb0ed28948102ff7538c73a224f74a96ee909fe66e30d64ca8cd80f792452d2
diff --git a/PKGBUILD b/PKGBUILD
index 4cda08ac70de..458a5e21be01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,26 @@
# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
pkgname=buildstream
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Framework for modelling build pipelines in a declarative YAML format"
arch=('any')
url="https://wiki.gnome.org/Projects/BuildStream/"
license=('LGPL')
depends=('bubblewrap' 'ostree' 'python-blessings' 'python-click'
'python-jinja' 'python-gobject' 'python-pluginbase'
- 'python-psutil' 'python-ruamel-yaml')
+ 'python-psutil' 'python-ruamel-yaml'
+ # host site dependencies
+ 'bubblewrap' 'bzr' 'git' 'lzip')
makedepends=('python-setuptools')
source=("https://download.gnome.org/sources/BuildStream/${pkgver%.*}/BuildStream-$pkgver.tar.xz")
sha256sums=('3fb0ed28948102ff7538c73a224f74a96ee909fe66e30d64ca8cd80f792452d2')
+build() {
+ cd BuildStream-$pkgver
+ python setup.py build
+}
+
package() {
- cd BuildStream-$pkgver
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd BuildStream-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}