summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore22
-rw-r--r--PKGBUILD40
3 files changed, 92 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e5f26d8eb7e0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = buildstream-devel
+ pkgdesc = A powerful and flexible software integration toolset
+ pkgver = 1.93.6
+ pkgrel = 1
+ url = https://buildstream.build
+ arch = x86_64
+ license = LGPL
+ makedepends = python-setuptools
+ makedepends = cython
+ depends = bubblewrap
+ depends = buildbox-casd
+ depends = python-click
+ depends = python-dateutil
+ depends = python-grpcio
+ depends = python-jinja
+ depends = python-pluginbase
+ depends = python-protobuf
+ depends = python-psutil
+ depends = python-pyroaring
+ depends = python-ruamel-yaml
+ depends = python-ujson
+ depends = git
+ depends = lzip
+ provides = buildstream
+ conflicts = buildstream
+ source = buildstream-devel-1.93.6.tar.gz::https://github.com/apache/buildstream/archive/refs/tags/1.93.6.tar.gz
+ sha256sums = 377876c169162227c087ebde4f8543c556b894f37d9bc3d8cb23b2d3db707f47
+
+pkgname = buildstream-devel
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ddfe915b4f92
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,22 @@
+# ignore everything ...
+*
+
+# ... except itself
+!.gitignore
+
+# ... except changes in package
+!PKGBUILD
+!.SRCINFO
+
+# ... except possible source files
+!*.patch
+!*.diff
+!*.desktop
+!*.png
+!LICENSE
+!*.service
+!*.conf
+
+# ... except files from PKGBUILD fields
+!*.changelog
+!*.install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..125aff56bfa3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Rafael Fontenelle <rafaelff@gnome.org>
+pkgname=buildstream-devel
+pkgver=1.93.6
+pkgrel=1
+pkgdesc="A powerful and flexible software integration toolset"
+arch=('x86_64')
+url="https://buildstream.build"
+license=('LGPL')
+depends=(
+ bubblewrap
+ buildbox-casd
+ python-click
+ python-dateutil
+ python-grpcio
+ python-jinja
+ python-pluginbase
+ python-protobuf
+ python-psutil
+ python-pyroaring
+ python-ruamel-yaml
+ python-ujson
+ # specific host site dependencies
+ git lzip
+)
+
+makedepends=(python-setuptools cython)
+provides=('buildstream')
+conflicts=('buildstream')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/apache/buildstream/archive/refs/tags/$pkgver.tar.gz")
+sha256sums=('377876c169162227c087ebde4f8543c556b894f37d9bc3d8cb23b2d3db707f47')
+
+build() {
+ cd buildstream-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd buildstream-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}