summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..604506c0e612
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = bukubrow-bin
+ pkgdesc = Host application for the Bukubrow WebExtension, precompiled
+ pkgver = 5.2.0
+ pkgrel = 1
+ url = https://github.com/samhh/bukubrow-host/
+ arch = x86_64
+ license = GPL3
+ conflicts = bukubrow
+ source = https://github.com/samhh/bukubrow-host//releases/download/v5.2.0/bukubrow-linux-amd64
+ sha256sums = ab7f3a6cade0875e34c8962f6a6c3af138e607cb95e1d2cf58dba58075bc5d81
+
+pkgname = bukubrow-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7604f8750c7d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Sam A. Horvath-Hunt <hello@samhh.com>
+
+_pkgname=bukubrow
+pkgname=bukubrow-bin
+pkgver=5.2.0
+pkgrel=1
+pkgdesc="Host application for the Bukubrow WebExtension, precompiled"
+url="https://github.com/samhh/bukubrow-host/"
+conflicts=('bukubrow')
+arch=('x86_64')
+license=('GPL3')
+source=("${url}/releases/download/v${pkgver}/bukubrow-linux-amd64")
+sha256sums=('dee9c73dae36f62b82b0b073ea2f69acc91249345842156d6f2ee0a15b97f247')
+
+package() {
+ install -Dm755 "$srcdir/bukubrow-linux-amd64" "$pkgdir/usr/bin/$_pkgname"
+}
+