summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD90
-rw-r--r--bunq-desktop-src.desktop2
4 files changed, 39 insertions, 70 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a1af28e0ec6..5f36aa94950f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = bunq-desktop-src
pkgdesc = A desktop implementation for the bunq API
- pkgver = 0.8.2
+ pkgver = 0.9.10
pkgrel = 1
- url = https://github.com/BunqCommunity/BunqDesktop
+ url = https://github.com/bunqCommunity/bunqDesktop
arch = x86_64
license = MIT
+ makedepends = yarn
+ makedepends = python2
+ makedepends = npm
+ makedepends = desktop-file-utils
depends = nodejs
provides = bunq-desktop
conflicts = bunq-desktop-git
conflicts = bunq-desktop-bin
- source = https://github.com/BunqCommunity/BunqDesktop/archive/0.8.2.tar.gz
+ source = https://github.com/bunqCommunity/bunqDesktop/archive/0.9.10.tar.gz
source = bunq-desktop-src.desktop
- sha256sums = a454aee04f3397b551000362ef2883ad4584a9eb37f2b9d5f311487aebf74ecc
- sha256sums = 1d84f185830733bb38928fcaa33ffc0ba46140f7f116b4d5ad24c93a585a0ffa
+ sha256sums = 98560c229d52b6696f14e31dcf62c70d2ebada9c85a76e65e26cc0dcc8ffb22f
+ sha256sums = 97183aab64799aec2462ba81cbb9cdbdf8617e1e6a843270a0ca07ca14fe2a49
pkgname = bunq-desktop-src
diff --git a/.gitignore b/.gitignore
index 34cefa7d88c4..924dfb95c209 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,3 @@
pkg/
src/
-*.tar.gz
-
+*.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index d7e63fdd56bc..3e4105712cdf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Stephanie Wilde-Hobbs <git@stephanie.is>
# Maintainer: Rolf van Kleef <aur@rolfvankleef.nl>
# Contributor: Gregory Goijaerts <crecketgaming@gmail.com>
# Contributor: Dennis Snijder <dennissnijder97@gmail.com>
@@ -8,79 +9,44 @@
# Contributor: Emile Bons
pkgname="bunq-desktop-src"
-pkgver="0.8.2"
+pkgver="0.9.10"
pkgrel=1
pkgdesc="A desktop implementation for the bunq API"
-url="https://github.com/BunqCommunity/BunqDesktop"
+url="https://github.com/bunqCommunity/bunqDesktop"
provides=('bunq-desktop')
-conflicts=(
- 'bunq-desktop-git'
- 'bunq-desktop-bin'
-)
-
-arch=(
- 'x86_64'
-)
-
-license=(
- 'MIT'
-)
-
-depends=(
- 'nodejs'
-)
-
-makedepens=(
- 'git'
- 'yarn'
-)
-
-source=(
- "https://github.com/BunqCommunity/BunqDesktop/archive/${pkgver}.tar.gz"
- "bunq-desktop-src.desktop"
-)
-
-sha256sums=(
- "a454aee04f3397b551000362ef2883ad4584a9eb37f2b9d5f311487aebf74ecc"
- "1d84f185830733bb38928fcaa33ffc0ba46140f7f116b4d5ad24c93a585a0ffa"
-)
+conflicts=('bunq-desktop-git' 'bunq-desktop-bin')
+arch=('x86_64')
+license=('MIT')
+depends=('nodejs')
+makedepends=('yarn' 'python2' 'npm' 'desktop-file-utils')
+source=("${url}/archive/${pkgver}.tar.gz"
+ "bunq-desktop-src.desktop")
+sha256sums=('98560c229d52b6696f14e31dcf62c70d2ebada9c85a76e65e26cc0dcc8ffb22f'
+ '97183aab64799aec2462ba81cbb9cdbdf8617e1e6a843270a0ca07ca14fe2a49')
build() {
- cd BunqDesktop-$pkgver
+ cd bunqDesktop-${pkgver}
+
+ sed -i '/plugin-syntax-dynamic-import/d' package.json
+ sed -i '/@babel/ s/7.7.[0-9]/7.8.4/' package.json
- # Generate release files
- yarn && yarn release
+ yarn
+ yarn release
}
package() {
- mkdir $pkgdir/usr
- mkdir $pkgdir/usr/bin
- mkdir $pkgdir/usr/share
- mkdir $pkgdir/usr/share/pixmaps
- mkdir $pkgdir/opt
-
- cp -R\
- BunqDesktop-$pkgver/dist/linux-unpacked\
- $pkgdir/opt/$pkgname
-
- cp -R\
- BunqDesktop-$pkgver/LICENSE\
- $pkgdir
-
- cp\
- BunqDesktop-$pkgver/build/icons/512x512.png\
- $pkgdir/usr/share/pixmaps/bunq.png
-
- pushd $pkgdir/usr/bin
+ cd bunqDesktop-${pkgver}
- ln -s\
- ../../opt/$pkgname/bunqdesktop\
- bunq-desktop-src
+ mkdir ${pkgdir}/usr
+ mkdir ${pkgdir}/usr/bin
+ mkdir ${pkgdir}/usr/share
+ mkdir ${pkgdir}/usr/share/pixmaps
+ mkdir ${pkgdir}/opt
- popd
+ cp -R dist/linux-unpacked ${pkgdir}/opt/${pkgname}
+ ln -s /opt/${pkgname}/bunqdesktop ${pkgdir}/usr/bin/bunq-desktop
- desktop-file-install\
- $pkgname.desktop\
- --dir $pkgdir/usr/share/applications/
+ cp build/icons/512x512.png ${pkgdir}/usr/share/pixmaps/bunq.png
+ desktop-file-install ${srcdir}/${pkgname}.desktop --dir ${pkgdir}/usr/share/applications/
}
diff --git a/bunq-desktop-src.desktop b/bunq-desktop-src.desktop
index 98fc34a31d15..fffb3d7e971a 100644
--- a/bunq-desktop-src.desktop
+++ b/bunq-desktop-src.desktop
@@ -2,7 +2,7 @@
Encoding=UTF-8
Name=Bunq Desktop
Comment=A desktop implementation for the bunq API.
-Exec=bunq-desktop-src -- %u
+Exec=bunq-desktop -- %u
StartupWMClass=BunqDesktop
Icon=bunq
Terminal=false