summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
-rw-r--r--butler.sh2
3 files changed, 8 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57a9174abde..57d588e1d238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = butler
pkgdesc = Command-line itch.io helper
pkgver = 15.21.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/itchio/butler
arch = x86_64
license = MIT
- source = butler.sh
source = butler-15.21.0.zip::https://broth.itch.ovh/butler/linux-amd64/15.21.0/archive/default
- sha256sums = 4db49b277678905279f323751b1d8704213549b45ed9332310b78f5421d8da7d
sha256sums = b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c
pkgname = butler
diff --git a/PKGBUILD b/PKGBUILD
index 7c9eac01f579..4af3e28917d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=butler
pkgver=15.21.0
-pkgrel=2
+pkgrel=3
pkgdesc='Command-line itch.io helper'
arch=('x86_64')
url='https://github.com/itchio/butler'
license=('MIT')
-source=("butler.sh"
- "$pkgname-$pkgver.zip::https://broth.itch.ovh/butler/linux-amd64/$pkgver/archive/default")
-sha256sums=('4db49b277678905279f323751b1d8704213549b45ed9332310b78f5421d8da7d'
- 'b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c')
+source=("$pkgname-$pkgver.zip::https://broth.itch.ovh/butler/linux-amd64/$pkgver/archive/default")
+sha256sums=('b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c')
package() {
- install -Dm755 butler.sh "$pkgdir/usr/bin/butler"
install -Dm755 butler -t "$pkgdir/usr/lib/butler"
- install -Dm755 *.so -t "$pkgdir/usr/lib/butler"
+ install -Dm755 ./*.so -t "$pkgdir/usr/lib/butler"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "../lib/butler/butler" "$pkgdir/usr/bin/butler"
}
diff --git a/butler.sh b/butler.sh
deleted file mode 100644
index 6cdea8ef558e..000000000000
--- a/butler.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/usr/bin/env bash
-exec /usr/lib/butler/butler "$@"