summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--butler.sh2
3 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa2def2aa3ad..57d588e1d238 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,11 @@
pkgbase = butler
pkgdesc = Command-line itch.io helper
- pkgver = 15.19.0
- pkgrel = 1
+ pkgver = 15.21.0
+ pkgrel = 3
url = https://github.com/itchio/butler
arch = x86_64
license = MIT
- source = butler.sh
- source = https://broth.itch.ovh/butler/linux-amd64/15.19.0/archive/default
- sha256sums = 139d933a14939a6822cee27294aac9730d45d81dc7257d5dcd8a5f46913492a1
- sha256sums = 9f000f975c178c96a2121eca5a55bca3535369634f1a33866e2dc5a02fcb3764
+ source = butler-15.21.0.zip::https://broth.itch.ovh/butler/linux-amd64/15.21.0/archive/default
+ sha256sums = b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c
pkgname = butler
-
diff --git a/PKGBUILD b/PKGBUILD
index dbac68d753b9..4af3e28917d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Carlo Cabanilla <carlo.cabanilla@gmail.com>
pkgname=butler
-pkgver=15.19.0
-pkgrel=1
+pkgver=15.21.0
+pkgrel=3
pkgdesc='Command-line itch.io helper'
arch=('x86_64')
url='https://github.com/itchio/butler'
license=('MIT')
-source=("butler.sh"
- "https://broth.itch.ovh/butler/linux-amd64/$pkgver/archive/default")
-sha256sums=('139d933a14939a6822cee27294aac9730d45d81dc7257d5dcd8a5f46913492a1'
- '9f000f975c178c96a2121eca5a55bca3535369634f1a33866e2dc5a02fcb3764')
+source=("$pkgname-$pkgver.zip::https://broth.itch.ovh/butler/linux-amd64/$pkgver/archive/default")
+sha256sums=('b640fceade5cafc7601b0ee57ba13c85913917eb5440375f7a605126f9ca2e1c')
package() {
- install -Dm755 butler.sh "$pkgdir/usr/bin/butler"
install -Dm755 butler -t "$pkgdir/usr/lib/butler"
- install -Dm755 *.so -t "$pkgdir/usr/lib/butler"
+ install -Dm755 ./*.so -t "$pkgdir/usr/lib/butler"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "../lib/butler/butler" "$pkgdir/usr/bin/butler"
}
diff --git a/butler.sh b/butler.sh
deleted file mode 100644
index 90cd8c7d4797..000000000000
--- a/butler.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/usr/bin/env bash
-/usr/lib/butler/butler "$@"