summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..20a80da604c4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = button
+ pkgdesc = A fast, correct, and robust build system
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/jasonwhite/button
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = dmd
+ makedepends = dub
+ depends = sqlite
+ optdepends = strace: For automatic dependency detection (highly recommended)
+ optdepends = button-lua: For writing build descriptions in Lua (highly recommended)
+ source = https://github.com/jasonwhite/button/archive/v0.0.1/button-0.0.1.tar.gz
+ md5sums = 8b01fddfe4a319d9ed62898d406fcb62
+
+pkgname = button
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e08ec70a3033
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jason White <jasonaw0 at gmail dot com>
+pkgname=button
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A fast, correct, and robust build system"
+arch=('i686' 'x86_64')
+url="https://github.com/jasonwhite/$pkgname"
+license=('MIT')
+depends=('sqlite')
+optdepends=('strace: For automatic dependency detection (highly recommended)'
+ 'button-lua: For writing build descriptions in Lua (highly recommended)')
+makedepends=('dmd' 'dub')
+source=("https://github.com/jasonwhite/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('8b01fddfe4a319d9ed62898d406fcb62')
+
+build() {
+ cd "$pkgname-$pkgver"
+ dub build --build=release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+}