summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 29c6bde8524e..060fe21afbda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = bwa-mem2-git
pkgdesc = The next version of Burrows-Wheeler Aligner MEM algorithm
- pkgver = r83.a06c1af
+ pkgver = r183.d43752d
pkgrel = 1
url = https://github.com/bwa-mem2/bwa-mem2
arch = i686
@@ -9,6 +9,8 @@ pkgbase = bwa-mem2-git
depends = gcc-libs
depends = zlib
source = git+https://github.com/bwa-mem2/bwa-mem2
+ source = git+https://github.com/intel/safestringlib.git
+ md5sums = SKIP
md5sums = SKIP
pkgname = bwa-mem2-git
diff --git a/PKGBUILD b/PKGBUILD
index 4333e46167ff..973671348f80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=bwa-mem2-git
_pkgname=bwa-mem2
-pkgver=r83.a06c1af
+pkgver=r183.d43752d
pkgrel=1
pkgdesc="The next version of Burrows-Wheeler Aligner MEM algorithm"
arch=('i686' 'x86_64')
url="https://github.com/bwa-mem2/bwa-mem2"
license=('custom')
depends=('gcc-libs' 'zlib')
-source=("git+https://github.com/bwa-mem2/bwa-mem2")
-md5sums=('SKIP')
+source=("git+https://github.com/bwa-mem2/bwa-mem2"
+ "git+https://github.com/intel/safestringlib.git")
+md5sums=('SKIP' 'SKIP')
# For compiling for native instruction set only, set this to false:
MULTI=${MULTI:-true}
@@ -20,6 +21,13 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ git config submodule.ext/safestringlib.url ${srcdir}/safestringlib
+ git submodule update
+}
+
build() {
cd "$srcdir/$_pkgname"
if [ "$MULTI" = true ] ; then
@@ -32,7 +40,7 @@ build() {
package() {
cd "$srcdir/$_pkgname"
install -Dm755 bwa-mem2 "$pkgdir/usr/bin/bwa-mem2"
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
if [ "$MULTI" = true ] ; then
install -Dm755 bwa-mem2.avx2 "$pkgdir/usr/bin/bwa-mem2.avx2"