summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD10
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f735e6c49196..1f0693e8a354 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = c2nim-git
pkgdesc = Tool to translate ANSI C code to Nim
pkgver = 0.9.18.r36.6d35d93
- pkgrel = 1
+ pkgrel = 2
epoch = 1
url = https://github.com/nim-lang/c2nim
arch = i686
@@ -12,7 +12,7 @@ pkgbase = c2nim-git
depends = glibc
depends = gcc-libs
optdepends = nim: compile generated code
- provides = c2nim
+ provides = c2nim=0.9.18
conflicts = c2nim
source = git+https://github.com/nim-lang/c2nim.git?signed
validpgpkeys = 5DE3E0509C47EA3CF04A42D34AEE18F83AFDEB23
diff --git a/.gitignore b/.gitignore
index 05c6d4d4c97b..713f6f80aff8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-*
-!.gitignore
-!.SRCINFO
-!PKGBUILD
+/*
+!/.gitignore
+!/.SRCINFO
+!/PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
index 11b78ef9a517..c49781c68a22 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname=c2nim
pkgname="$_pkgname-git"
pkgver=0.9.18.r36.6d35d93
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Tool to translate ANSI C code to Nim"
arch=(i686 x86_64)
@@ -12,7 +12,7 @@ license=(MIT)
depends=(glibc gcc-libs)
makedepends=(choosenim git)
optdepends=('nim: compile generated code')
-provides=("$_pkgname")
+provides=("$_pkgname=${pkgver%%.r*}")
conflicts=("$_pkgname")
source=("git+$url.git?signed")
b2sums=('SKIP')
@@ -44,7 +44,7 @@ build() {
package() {
cd $_pkgname
- install -Dm755 $_pkgname -t "$pkgdir/usr/bin/"
- install -Dm644 "doc/$_pkgname.rst" README.md -t "$pkgdir/usr/share/doc/$_pkgname/"
- install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$_pkgname/LICENSE"
+ install -vDm755 $_pkgname -t "$pkgdir/usr/bin/"
+ install -vDm644 "doc/$_pkgname.rst" README.md -t "$pkgdir/usr/share/doc/$_pkgname/"
+ install -vDm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}