summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--flake.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 000000000000..9b9ea24d1271
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,12 @@
+{
+ description = "dn42 root certificates for *.dn42 and 172.22.0.0/15";
+ outputs = { self }: {
+ nixosModule = { config, lib, ... }: {
+ options.security.pki.dn42.enable =
+ lib.mkEnableOption "dn42 root certificates";
+
+ security.pki.certificateFiles =
+ lib.mkIf config.options.security.pki.dn42.enable [ ./dn42.crt ];
+ };
+ };
+}