summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD6
-rw-r--r--package.patch45
2 files changed, 39 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6e1ff4d1cb4..35d97600af8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname='cadabra2-git'
-pkgver=r701.a17ad42
-pkgrel=4
+pkgver=r715.1a663ef
+pkgrel=1
pkgdesc="A computer algebra system (pre-release version) designed specifically for the solution of problems encountered in field theory."
arch=('i686' 'x86_64')
url="http://cadabra.phi-sci.com/"
@@ -12,7 +12,7 @@ depends=('python2-matplotlib' 'gtkmm3' 'jsoncpp' 'mathjax' 'boost-libs' 'python2
makedepends=('cmake')
source=("$pkgname::git+https://github.com/kpeeters/cadabra2" "package.patch")
md5sums=('SKIP'
- '7eaf565d2558304a454d2669effa2630')
+ 'b47f6f1b88aba9b53ceee98750bb1165')
install=package.install
diff --git a/package.patch b/package.patch
index 89d2db90fd53..4eb8bae3b2f6 100644
--- a/package.patch
+++ b/package.patch
@@ -1,9 +1,36 @@
-diff -aur -bZwB -x .git cadabra2-git.old/core/cadabra2 cadabra2-git/core/cadabra2
---- cadabra2-git.old/core/cadabra2.in 2016-03-08 06:55:56.245442657 -0500
-+++ cadabra2-git/core/cadabra2.in 2016-03-08 06:56:27.278519443 -0500
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python2
- #
- # \ingroup pythoncore
- #
+diff -aur -bZwB -x .git cadabra2-git.old/client_server/CMakeLists.txt cadabra2-git/client_server/CMakeLists.txt
+--- cadabra2-git.old/client_server/CMakeLists.txt 2016-05-21 14:48:27.205019749 -0400
++++ cadabra2-git/client_server/CMakeLists.txt 2016-05-21 14:49:28.927905642 -0400
+@@ -33,7 +33,7 @@
+ find_package(Boost 1.54.0 COMPONENTS python3
+ system regex program_options REQUIRED)
+ else()
+- find_package(Boost 1.54.0 COMPONENTS python-py34 system regex program_options REQUIRED)
++ find_package(Boost 1.54.0 COMPONENTS python3 system regex program_options REQUIRED)
+ endif()
+ set(Boost_USE_STATIC_LIBS OFF)
+ set(Boost_USE_MULTITHREADED ON)
+diff -aur -bZwB -x .git cadabra2-git.old/core/CMakeLists.txt cadabra2-git/core/CMakeLists.txt
+--- cadabra2-git.old/core/CMakeLists.txt 2016-05-21 14:48:27.218352986 -0400
++++ cadabra2-git/core/CMakeLists.txt 2016-05-21 14:49:35.234526685 -0400
+@@ -33,7 +33,7 @@
+ if(APPLE)
+ find_package(Boost 1.54.0 COMPONENTS python3)
+ else()
+- find_package(Boost 1.54.0 COMPONENTS python-py34)
++ find_package(Boost 1.54.0 COMPONENTS python3)
+ endif()
+
+ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")
+diff -aur -bZwB -x .git cadabra2-git.old/frontend/gtkmm/Cadabra.hh cadabra2-git/frontend/gtkmm/Cadabra.hh
+--- cadabra2-git.old/frontend/gtkmm/Cadabra.hh 2016-05-21 14:48:27.235019531 -0400
++++ cadabra2-git/frontend/gtkmm/Cadabra.hh 2016-05-21 14:49:55.931043749 -0400
+@@ -20,7 +20,7 @@
+ void on_open(const Gio::Application::type_vec_files& files, const Glib::ustring& hint) override;
+
+ private:
+- std::vector<cadabra::NotebookWindow> windows;
++ cadabra::NotebookWindow nw;
+ cadabra::ComputeThread compute;
+ std::thread compute_thread;
+ };