summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
-rw-r--r--package.patch24
3 files changed, 10 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1011cef8f60..df599040eefe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat May 21 20:08:45 UTC 2016
+# Sun May 22 17:17:15 UTC 2016
pkgbase = cadabra2-git
pkgdesc = A computer algebra system (pre-release version) designed specifically for the solution of problems encountered in field theory.
- pkgver = r716.6c7ef1c
+ pkgver = r721.b39670b
pkgrel = 1
url = http://cadabra.phi-sci.com/
install = package.install
@@ -10,18 +10,17 @@ pkgbase = cadabra2-git
arch = x86_64
license = GPL
makedepends = cmake
- depends = python2-matplotlib
+ makedepends = boost
+ depends = python-matplotlib
depends = gtkmm3
depends = jsoncpp
depends = mathjax
depends = boost-libs
- depends = python2-sympy
+ depends = python-sympy
provides = cadabra2
conflicts = cadabra2
source = cadabra2-git::git+https://github.com/kpeeters/cadabra2
- source = package.patch
md5sums = SKIP
- md5sums = 0b5e5e066145f974b8be4f92af0055f0
pkgname = cadabra2-git
diff --git a/PKGBUILD b/PKGBUILD
index a52b8a0ce2ed..28c47f9a7dd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tarn Burton <twburton at gmail dot com>
pkgname='cadabra2-git'
-pkgver=r716.6c7ef1c
+pkgver=r721.b39670b
pkgrel=1
pkgdesc="A computer algebra system (pre-release version) designed specifically for the solution of problems encountered in field theory."
arch=('i686' 'x86_64')
@@ -8,11 +8,10 @@ url="http://cadabra.phi-sci.com/"
license=('GPL')
provides=('cadabra2')
conflicts=('cadabra2')
-depends=('python2-matplotlib' 'gtkmm3' 'jsoncpp' 'mathjax' 'boost-libs' 'python2-sympy')
-makedepends=('cmake')
-source=("$pkgname::git+https://github.com/kpeeters/cadabra2" "package.patch")
-md5sums=('SKIP'
- '0b5e5e066145f974b8be4f92af0055f0')
+depends=('python-matplotlib' 'gtkmm3' 'jsoncpp' 'mathjax' 'boost-libs' 'python-sympy')
+makedepends=('cmake' 'boost')
+source=("$pkgname::git+https://github.com/kpeeters/cadabra2")
+md5sums=('SKIP')
install=package.install
@@ -21,11 +20,6 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "${srcdir}/${pkgname}"
- patch -Np1 -i ../package.patch
-}
-
build() {
cd $pkgname
mkdir -p build
diff --git a/package.patch b/package.patch
deleted file mode 100644
index 5eea40ae12da..000000000000
--- a/package.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -aur -bZwB -x .git cadabra2-git.old/client_server/CMakeLists.txt cadabra2-git/client_server/CMakeLists.txt
---- cadabra2-git.old/client_server/CMakeLists.txt 2016-05-21 16:07:27.620746479 -0400
-+++ cadabra2-git/client_server/CMakeLists.txt 2016-05-21 16:08:03.087295612 -0400
-@@ -33,7 +33,7 @@
- find_package(Boost 1.54.0 COMPONENTS python3
- system regex program_options REQUIRED)
- else()
-- find_package(Boost 1.54.0 COMPONENTS python-py34 system regex program_options REQUIRED)
-+ find_package(Boost 1.54.0 COMPONENTS python3 system regex program_options REQUIRED)
- endif()
- set(Boost_USE_STATIC_LIBS OFF)
- set(Boost_USE_MULTITHREADED ON)
-diff -aur -bZwB -x .git cadabra2-git.old/core/CMakeLists.txt cadabra2-git/core/CMakeLists.txt
---- cadabra2-git.old/core/CMakeLists.txt 2016-05-21 16:07:27.634079768 -0400
-+++ cadabra2-git/core/CMakeLists.txt 2016-05-21 16:08:12.737263557 -0400
-@@ -33,7 +33,7 @@
- if(APPLE)
- find_package(Boost 1.54.0 COMPONENTS python3)
- else()
-- find_package(Boost 1.54.0 COMPONENTS python-py34)
-+ find_package(Boost 1.54.0 COMPONENTS python3)
- endif()
-
- if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "Clang")