summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 715632c8be70..8109da46ceb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,10 +9,14 @@ pkgbase = caddy
arch = armv6h
license = Apache
conflicts = caddy-git
- source = https://github.com/mholt/caddy/releases/download/v0.8.2/caddy_linux_amd64.tar.gz
source = caddy.service
- sha256sums = 497ddf916b1d38e5435c4bd996b89c208ecb6dc05cf447381e549d39a616db4b
sha256sums = 244fa03febae623f1b10adfb6883a9573ba81747b8e535bb23101ab230ccbf95
+ source_i686 = https://github.com/mholt/caddy/releases/download/v0.8.2/caddy_linux_386.tar.gz
+ sha256sums_i686 = 0012f54d09ae6bad96f86554aad6eb2d7c1f08bb7d9a72fdf640a53b0542352a
+ source_x86_64 = https://github.com/mholt/caddy/releases/download/v0.8.2/caddy_linux_amd64.tar.gz
+ sha256sums_x86_64 = 497ddf916b1d38e5435c4bd996b89c208ecb6dc05cf447381e549d39a616db4b
+ source_armv6h = https://github.com/mholt/caddy/releases/download/v0.8.2/caddy_linux_arm.tar.gz
+ sha256sums_armv6h = 7e9ad0171f9cdd78a95b35e19cc973b9a8108f391a3fafa4c05d4201248e4627
pkgname = caddy
diff --git a/PKGBUILD b/PKGBUILD
index cd691e788cac..9a1e798ab34a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,14 +11,17 @@ license=('Apache')
install='caddy.install'
conflicts=('caddy-git')
-[ "$CARCH" = 'i686' ] && _suffix='386' && _hash='0012f54d09ae6bad96f86554aad6eb2d7c1f08bb7d9a72fdf640a53b0542352a'
-[ "$CARCH" = 'x86_64' ] && _suffix='amd64' && _hash='497ddf916b1d38e5435c4bd996b89c208ecb6dc05cf447381e549d39a616db4b'
-[ "$CARCH" = 'armv6h' ] && _suffix='arm' && _hash='7e9ad0171f9cdd78a95b35e19cc973b9a8108f391a3fafa4c05d4201248e4627'
+source=('caddy.service')
+sha256sums=('244fa03febae623f1b10adfb6883a9573ba81747b8e535bb23101ab230ccbf95')
-source=("https://github.com/mholt/caddy/releases/download/v$pkgver/caddy_linux_$_suffix.tar.gz"
- 'caddy.service')
-sha256sums=("${_hash}"
- '244fa03febae623f1b10adfb6883a9573ba81747b8e535bb23101ab230ccbf95')
+source_i686=("https://github.com/mholt/caddy/releases/download/v$pkgver/caddy_linux_386.tar.gz")
+sha256sums_i686=('0012f54d09ae6bad96f86554aad6eb2d7c1f08bb7d9a72fdf640a53b0542352a')
+
+source_x86_64=("https://github.com/mholt/caddy/releases/download/v$pkgver/caddy_linux_amd64.tar.gz")
+sha256sums_x86_64=('497ddf916b1d38e5435c4bd996b89c208ecb6dc05cf447381e549d39a616db4b')
+
+source_armv6h=("https://github.com/mholt/caddy/releases/download/v$pkgver/caddy_linux_arm.tar.gz")
+sha256sums_armv6h=('7e9ad0171f9cdd78a95b35e19cc973b9a8108f391a3fafa4c05d4201248e4627')
package() {
install -Dm755 "$srcdir/caddy" "$pkgdir/usr/bin/caddy"