summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD17
-rw-r--r--noquic_aesni.patch35
-rw-r--r--plugins.patch2
4 files changed, 38 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c6299cf9ce2..69d4e007d016 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = caddy-with-cgi
pkgdesc = HTTP/2 Web Server with Automatic HTTPS, with caddy-cgi plugin and gcc-go support
- pkgver = 1.0.0
- pkgrel = 2
+ pkgver = 1.0.1
+ pkgrel = 1
url = https://caddyserver.com
install = caddy.install
arch = i686
@@ -13,8 +13,8 @@ pkgbase = caddy-with-cgi
provides = caddy
conflicts = caddy
backup = etc/caddy/caddy.conf
- source = https://github.com/mholt/caddy/archive/v1.0.0/caddy-1.0.0.tar.gz
- source = https://github.com/jung-kurt/caddy-cgi/archive/v1.10.tar.gz
+ source = https://github.com/caddyserver/caddy/archive/v1.0.1/caddy-1.0.1.tar.gz
+ source = https://github.com/jung-kurt/caddy-cgi/archive/v1.11.4.tar.gz
source = https://caddyserver.com/resources/images/brand/caddy-at-your-service-white.svg
source = index.html
source = caddy.service
@@ -22,15 +22,15 @@ pkgbase = caddy-with-cgi
source = caddy.conf
source = noquic_aesni.patch
source = plugins.patch
- sha256sums = 1c8b435a79e21b9832c7a8a88c44e70bc80434ca3719853d2b1092ffbbbbff7d
- sha256sums = 4cb13ce2862dbd00e4a97342d5f20bc759e2c1b7983f866aa4b6d421df65249b
+ sha256sums = 7cbd80c798a0db4195381f730f5409680c6e1239fbc06295b90b34f666a05692
+ sha256sums = a1c3982093f599b11b05ed9040fb3c0d8da960023226c82f125dbbb0cac9634f
sha256sums = e679dd79fd92dc351fc190c7af529c73e3896986aaa6b7c0ae01e561398d6b85
sha256sums = 6db7aec45e95bbbf770ce4d120a60d8e4992d2262a8ebf668521179279aa5ae7
sha256sums = 69e25def317a6172011472bd060655142f3085a0c81392f8a7a9c42b6a58bbd9
sha256sums = bd4d912d083be176727882ccc1bbe577a27cc160db09238e5edc05ba458aebce
sha256sums = 80520b80ccabf077a3269f6a1bf55faa3811ef5adce115131b35ef2044d37b64
- sha256sums = 03c676ed4cd6467310ba47c8a8874a95a773263115d56001f220c1972e4a3230
- sha256sums = 19aa631a55d74aba2c79749c9ae67d7465d1428a072b303aedf1194190778347
+ sha256sums = 1c121388b2741bc8b02fe01950d2241e67fef5d2bd806486c108775007461c8a
+ sha256sums = bad12dd8ea996b4cd9dfeb60364fe266321da9dad93abe0f169f3f1b6f23f487
pkgname = caddy-with-cgi
diff --git a/PKGBUILD b/PKGBUILD
index c39981fa8e73..18d9ee53e5c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Eric Engeström <eric at engestrom dot ch>
# Contributor: Andreas Linz <klingt.net at gmail dot com>
-_gopkgname='github.com/mholt/caddy'
+_gopkgname='github.com/caddyserver/caddy'
_cgipkgname='github.com/jung-kurt/caddy-cgi'
# if you're building with gcc-go, then it'll fail to
@@ -20,9 +20,9 @@ fi
pkgname=caddy-with-cgi
_pkgbase=caddy
-pkgver=1.0.0
-_cgiver=1.10
-pkgrel=2
+pkgver=1.0.1
+_cgiver=1.11.4
+pkgrel=1
pkgdesc='HTTP/2 Web Server with Automatic HTTPS, with caddy-cgi plugin and gcc-go support'
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
url='https://caddyserver.com'
@@ -40,20 +40,21 @@ source=("https://$_gopkgname/archive/v$pkgver/$_pkgbase-$pkgver.tar.gz"
'caddy.conf'
'noquic_aesni.patch'
'plugins.patch')
-sha256sums=('1c8b435a79e21b9832c7a8a88c44e70bc80434ca3719853d2b1092ffbbbbff7d'
- '4cb13ce2862dbd00e4a97342d5f20bc759e2c1b7983f866aa4b6d421df65249b'
+sha256sums=('7cbd80c798a0db4195381f730f5409680c6e1239fbc06295b90b34f666a05692'
+ 'a1c3982093f599b11b05ed9040fb3c0d8da960023226c82f125dbbb0cac9634f'
'e679dd79fd92dc351fc190c7af529c73e3896986aaa6b7c0ae01e561398d6b85'
'6db7aec45e95bbbf770ce4d120a60d8e4992d2262a8ebf668521179279aa5ae7'
'69e25def317a6172011472bd060655142f3085a0c81392f8a7a9c42b6a58bbd9'
'bd4d912d083be176727882ccc1bbe577a27cc160db09238e5edc05ba458aebce'
'80520b80ccabf077a3269f6a1bf55faa3811ef5adce115131b35ef2044d37b64'
- '03c676ed4cd6467310ba47c8a8874a95a773263115d56001f220c1972e4a3230'
- '19aa631a55d74aba2c79749c9ae67d7465d1428a072b303aedf1194190778347')
+ '1c121388b2741bc8b02fe01950d2241e67fef5d2bd806486c108775007461c8a'
+ 'bad12dd8ea996b4cd9dfeb60364fe266321da9dad93abe0f169f3f1b6f23f487')
prepare() {
export GO111MODULE=on
mv -Tv "$srcdir/caddy-cgi-$_cgiver" "$srcdir/$_pkgbase-$pkgver/caddy-cgi"
cd "$srcdir/$_pkgbase-$pkgver"
+ rm -v "$srcdir/$_pkgbase-$pkgver/caddy-cgi/go.mod" "$srcdir/$_pkgbase-$pkgver/caddy-cgi/go.sum"
patch -p0 -i "$srcdir/plugins.patch"
# fix rewrite: rewrite the URI instead of just the path
# https://github.com/mholt/caddy/issues/2129
diff --git a/noquic_aesni.patch b/noquic_aesni.patch
index eca192a372d3..d7bf215c8dd0 100644
--- a/noquic_aesni.patch
+++ b/noquic_aesni.patch
@@ -1,5 +1,5 @@
diff --git a/caddyhttp/httpserver/server.go b/caddyhttp/httpserver/server.go
-index 7940ac8..71cc657 100644
+index 5368407b..be52e360 100644
--- a/caddyhttp/httpserver/server.go
+++ b/caddyhttp/httpserver/server.go
@@ -31,7 +31,6 @@ import (
@@ -7,9 +7,9 @@ index 7940ac8..71cc657 100644
"time"
- "github.com/lucas-clemente/quic-go/h2quic"
- "github.com/mholt/caddy"
- "github.com/mholt/caddy/caddyhttp/staticfiles"
- "github.com/mholt/caddy/caddytls"
+ "github.com/caddyserver/caddy"
+ "github.com/caddyserver/caddy/caddyhttp/staticfiles"
+ "github.com/caddyserver/caddy/caddytls"
@@ -41,7 +40,6 @@ import (
// Server is the HTTP server implementation.
type Server struct {
@@ -18,15 +18,20 @@ index 7940ac8..71cc657 100644
sites []*SiteConfig
connTimeout time.Duration // max time to wait for a connection before force stop
tlsGovChan chan struct{} // close to stop the TLS maintenance goroutine
-@@ -104,7 +102,6 @@ func NewServer(addr string, group []*SiteConfig) (*Server, error) {
+@@ -102,12 +100,6 @@ func NewServer(addr string, group []*SiteConfig) (*Server, error) {
+
+ // if TLS is enabled, make sure we prepare the Server accordingly
if s.Server.TLSConfig != nil {
- // enable QUIC if desired (requires HTTP/2)
- if HTTP2 && QUIC {
+- // enable QUIC if desired (requires HTTP/2)
+- if HTTP2 && QUIC {
- s.quicServer = &h2quic.Server{Server: s.Server}
- s.Server.Handler = s.wrapWithSvcHeaders(s.Server.Handler)
- }
-
-@@ -234,9 +231,6 @@ func makeHTTPServerWithTimeouts(addr string, group []*SiteConfig) *http.Server {
+- s.Server.Handler = s.wrapWithSvcHeaders(s.Server.Handler)
+- }
+-
+ // wrap the HTTP handler with a handler that does MITM detection
+ tlsh := &tlsHandler{next: s.Server.Handler}
+ s.Server.Handler = tlsh // this needs to be the "outer" handler when Serve() is called, for type assertion
+@@ -234,9 +226,6 @@ func makeHTTPServerWithTimeouts(addr string, group []*SiteConfig) *http.Server {
func (s *Server) wrapWithSvcHeaders(previousHandler http.Handler) http.HandlerFunc {
return func(w http.ResponseWriter, r *http.Request) {
@@ -36,7 +41,7 @@ index 7940ac8..71cc657 100644
previousHandler.ServeHTTP(w, r)
}
}
-@@ -324,14 +318,6 @@ func (s *Server) Serve(ln net.Listener) error {
+@@ -324,14 +313,6 @@ func (s *Server) Serve(ln net.Listener) error {
s.tlsGovChan = caddytls.RotateSessionTicketKeys(s.Server.TLSConfig)
}
@@ -51,7 +56,7 @@ index 7940ac8..71cc657 100644
err := s.Server.Serve(ln)
if err != nil && err != http.ErrServerClosed {
return err
-@@ -341,10 +327,6 @@ func (s *Server) Serve(ln net.Listener) error {
+@@ -341,10 +322,6 @@ func (s *Server) Serve(ln net.Listener) error {
// ServePacket serves QUIC requests on pc until it is closed.
func (s *Server) ServePacket(pc net.PacketConn) error {
@@ -63,7 +68,7 @@ index 7940ac8..71cc657 100644
}
diff --git a/caddyhttp/proxy/reverseproxy.go b/caddyhttp/proxy/reverseproxy.go
-index c20be0c..884fd4d 100644
+index a223d353..a4dfd056 100644
--- a/caddyhttp/proxy/reverseproxy.go
+++ b/caddyhttp/proxy/reverseproxy.go
@@ -41,8 +41,6 @@ import (
@@ -72,7 +77,7 @@ index c20be0c..884fd4d 100644
- "github.com/lucas-clemente/quic-go"
- "github.com/lucas-clemente/quic-go/h2quic"
- "github.com/mholt/caddy/caddyhttp/httpserver"
+ "github.com/caddyserver/caddy/caddyhttp/httpserver"
)
@@ -253,13 +251,6 @@ func NewSingleHostReverseProxy(target *url.URL, without string, keepalive int, t
diff --git a/plugins.patch b/plugins.patch
index 641bf9c5b814..322945f4bc14 100644
--- a/plugins.patch
+++ b/plugins.patch
@@ -4,7 +4,7 @@
"github.com/mholt/caddy/caddytls"
// This is where other plugins get plugged in (imported)
-+ _ "github.com/mholt/caddy/caddy-cgi"
++ _ "github.com/caddyserver/caddy/caddy-cgi"
)
func init() {