summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d41fc3d15854..56e5efdda868 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Sun Aug 6 13:20:29 UTC 2017
+# Sun Sep 3 15:40:18 UTC 2017
pkgbase = caffe
pkgdesc = A deep learning framework made with expression, speed, and modularity in mind (gpu enabled)
pkgver = 1.0
- pkgrel = 5
+ pkgrel = 6
url = http://caffe.berkeleyvision.org/
arch = x86_64
license = BSD
@@ -38,7 +38,6 @@ pkgbase = caffe
depends = python-pillow
depends = python-six
depends = openblas-lapack
- depends = nccl
depends = python-leveldb
depends = python-scikit-image
depends = python-pydotplus
diff --git a/PKGBUILD b/PKGBUILD
index 183cb1370d0a..492d2b49fdea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,13 @@
# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
# Contributor: Micah Chambers <micahc.vt@gmail.com>
+# NOTE:
+# In order to build with NCCL support, uncomment the NCCL
+# lines in 'depends' and 'preprare()'.
+
pkgname=caffe
pkgver=1.0
-pkgrel=5
+pkgrel=6
pkgdesc="A deep learning framework made with expression, speed, and modularity in mind (gpu enabled)"
arch=('x86_64')
url="http://caffe.berkeleyvision.org/"
@@ -18,8 +22,8 @@ depends=(
# AUR:
# required:
'openblas-lapack'
- # not required but enabled in build:
- 'nccl'
+ # not required:
+ # 'nccl'
# python:
'python-leveldb' 'python-scikit-image' 'python-pydotplus'
# NOTE:
@@ -42,7 +46,7 @@ prepare() {
sed -i '/USE_CUDNN/s/^#[[:space:]]//g' Makefile.config
# enable NCCL acceleration switch
- sed -i '/USE_NCCL/s/^#[[:space:]]//g' Makefile.config
+ # sed -i '/USE_NCCL/s/^#[[:space:]]//g' Makefile.config
# strictly enable I/O dependencies
sed -i '/USE_OPENCV/s/^#[[:space:]]//;/USE_OPENCV/s/0/1/' Makefile.config