summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rw-r--r--external-nnpack-fix.patch24
3 files changed, 3 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9e0908cbf9f1..f4d2abdd454c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jul 21 01:44:53 UTC 2017
+# Sun Aug 6 13:50:36 UTC 2017
pkgbase = caffe2-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)
pkgver = 0.7.0.r686.gb8f66c1c
- pkgrel = 1
+ pkgrel = 2
url = http://caffe2.ai/
arch = x86_64
license = BSD
@@ -57,7 +57,6 @@ pkgbase = caffe2-git
conflicts = caffe2-cpu-git
options = !emptydirs
source = caffe2-git::git+https://github.com/caffe2/caffe2.git
- source = external-nnpack-fix.patch
source = submodule-pybind11::git+https://github.com/pybind/pybind11.git
source = submodule-nccl::git+https://github.com/nvidia/nccl.git
source = submodule-cnmem::git+https://github.com/nvidia/cnmem.git
@@ -76,7 +75,6 @@ pkgbase = caffe2-git
source = submodule-NNPACK_deps-FP16::git+https://github.com/Maratyszcza/FP16.git
source = submodule-NNPACK_deps-psimd::git+https://github.com/Maratyszcza/psimd.git
sha256sums = SKIP
- sha256sums = 1c94a1ecc0fe2a52c50c9d1a7bfca655d60c08d48995b27c73aa22b6c375da54
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 64d94ad5b2b9..049889320d7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffe2-git
pkgver=0.7.0.r686.gb8f66c1c
-pkgrel=1
+pkgrel=2
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -41,7 +41,6 @@ options=('!emptydirs')
source=(
# main source:
"$pkgname"::'git+https://github.com/caffe2/caffe2.git'
- 'external-nnpack-fix.patch'
# git submodules:
'submodule-pybind11'::'git+https://github.com/pybind/pybind11.git'
'submodule-nccl'::'git+https://github.com/nvidia/nccl.git'
@@ -62,7 +61,6 @@ source=(
'submodule-NNPACK_deps-psimd'::'git+https://github.com/Maratyszcza/psimd.git'
)
sha256sums=('SKIP'
- '1c94a1ecc0fe2a52c50c9d1a7bfca655d60c08d48995b27c73aa22b6c375da54'
'SKIP'
'SKIP'
'SKIP'
@@ -101,11 +99,6 @@ prepare() {
# https://github.com/facebookincubator/gloo/issues/43
cd third_party/gloo
git checkout 21a5c8ea5e02edca03068790df3d7f7ba4e2d75b
-
- # avoid compile errors with nnpack if system library is found
- # https://github.com/caffe2/caffe2/pull/808
- cd "${srcdir}/${pkgname}"
- patch -Np1 -i "${srcdir}/external-nnpack-fix.patch"
}
pkgver() {
diff --git a/external-nnpack-fix.patch b/external-nnpack-fix.patch
deleted file mode 100644
index 08a4e0c4ca29..000000000000
--- a/external-nnpack-fix.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff --git a/cmake/Modules/FindNNPACK.cmake b/cmake/Modules/FindNNPACK.cmake
-index 547bf88f..29cf5dce 100644
---- a/cmake/Modules/FindNNPACK.cmake
-+++ b/cmake/Modules/FindNNPACK.cmake
-@@ -21,12 +21,17 @@ find_library(NNPACK_LIBRARY nnpack
- PATHS ${NNPACK_ROOT_DIR}
- PATH_SUFFIXES lib lib64)
-
--find_package_handle_standard_args(NNPACK DEFAULT_MSG NNPACK_INCLUDE_DIR NNPACK_LIBRARY)
-+find_library(PTHREADPOOL_LIBRARY pthreadpool
-+ PATHS ${NNPACK_ROOT_DIR}
-+ PATH_SUFFIXES lib lib64)
-+
-+find_package_handle_standard_args(NNPACK DEFAULT_MSG NNPACK_INCLUDE_DIR NNPACK_LIBRARY PTHREADPOOL_LIBRARY)
-
- if(NNPACK_FOUND)
- set(NNPACK_INCLUDE_DIRS ${NNPACK_INCLUDE_DIR})
-- set(NNPACK_LIBRARIES ${NNPACK_LIBRARY})
-+ set(NNPACK_LIBRARIES ${NNPACK_LIBRARY} ${PTHREADPOOL_LIBRARY})
- message(STATUS "Found NNPACK (include: ${NNPACK_INCLUDE_DIR}, library: ${NNPACK_LIBRARY})")
-+ message(STATUS "Found PTHREADPOOL (library: ${PTHREADPOOL_LIBRARY})")
- mark_as_advanced(NNPACK_ROOT_DIR NNPACK_LIBRARY_RELEASE NNPACK_LIBRARY_DEBUG
- NNPACK_LIBRARY NNPACK_INCLUDE_DIR)
- endif()