summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 71a376dca1f6..998f5924dd93 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Jun 15 01:59:39 UTC 2017
+# Thu Jun 15 19:24:10 UTC 2017
pkgbase = caffe2-git
pkgdesc = A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)
pkgver = 0.7.0.r434.g4c76b747
- pkgrel = 1
+ pkgrel = 2
url = http://caffe2.ai/
arch = x86_64
license = BSD
diff --git a/PKGBUILD b/PKGBUILD
index 9668cb62433e..7f919746392f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=caffe2-git
pkgver=0.7.0.r434.g4c76b747
-pkgrel=1
+pkgrel=2
pkgdesc='A new lightweight, modular, and scalable deep learning framework (git version, gpu enabled)'
arch=('x86_64')
url='http://caffe2.ai/'
@@ -77,15 +77,17 @@ sha256sums=('SKIP'
prepare() {
cd "$pkgname"
- _submodule_list="pybind11 nccl cnmem cub eigen googletest nervanagpu benchmark
- protobuf android-cmake ios-cmake NNPACK gloo NNPACK_deps/pthreadpool
- NNPACK_deps/FXdiv NNPACK_deps/FP16 NNPACK_deps/psimd"
+ local _submodule_list="pybind11 nccl cnmem cub eigen googletest nervanagpu benchmark \
+ protobuf android-cmake ios-cmake NNPACK gloo \
+ NNPACK_deps/pthreadpool NNPACK_deps/FXdiv NNPACK_deps/FP16 \
+ NNPACK_deps/psimd"
git submodule init
for _submodule in $_submodule_list
do
- _submodule_dir="submodule-$(printf "%s" "${_submodule}" | tr '/' '-')"
+ local _submodule_dir="submodule-$(printf "%s" "${_submodule}" | tr '/' '-')"
git config "submodule.third_party/${_submodule}.url" "${srcdir}/${_submodule_dir}"
done
+ unset _submodule
git submodule update
# avoid compile errors with gloo if using '-march=native' in a cpu with AVX2