summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD55
2 files changed, 39 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5131bf21596b..d2939a623375 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
-pkgbase = cairo-dock-wayland-git
+pkgbase = cairo-dock-core-wayland-git
pkgdesc = Light eye-candy fully themable animated dock with wayland support
- pkgver = 3.4.99.r.bf8da4ef
+ pkgver = 3.4.99.alpha1.20231227.85830c2c
pkgrel = 1
- url = http://glx-dock.org/
+ url = https://github.com/dkondor/cairo-dock-core
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = git
+ makedepends = extra-cmake-modules
depends = curl
depends = dbus-glib
depends = glu
depends = gtk3
depends = librsvg
depends = wayland
+ depends = gtk-layer-shell
optdepends = wayfire-plugins-scale-ipc: Additional functionality on wayfire
+ provides = cairo-dock-core-wayland
provides = cairo-dock
+ conflicts = cairo-dock-core-wayland
conflicts = cairo-dock
- source = cairo-dock::git+https://github.com/dkondor/cairo-dock-core.git#branch=wayland_new
+ source = cairo-dock-core-wayland-git::git+https://github.com/dkondor/cairo-dock-core.git#branch=wayland_new
sha256sums = SKIP
-pkgname = cairo-dock-wayland-git
+pkgname = cairo-dock-core-wayland-git
diff --git a/PKGBUILD b/PKGBUILD
index 873d71a5b646..6e39eedfc23c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,47 +2,52 @@
# Contributor: FreeByrd <nelsonbyrd248@gmail.com>
# Contributor: Tofe <chris.chapuis@gmail.com>
# Contributor: erm67 <erm67@yahoo.it>
+# Contributor: ssfdust <ssfdust@gmail.com>
-pkgname=cairo-dock-wayland-git
-pkgver=3.4.99.r.bf8da4ef
+pkgname=cairo-dock-core-wayland-git
+pkgver=3.4.99.alpha1.20231227.85830c2c
pkgrel=1
pkgdesc='Light eye-candy fully themable animated dock with wayland support'
arch=('i686' 'x86_64')
-url='http://glx-dock.org/'
+url='https://github.com/dkondor/cairo-dock-core'
license=('GPL')
-depends=('curl' 'dbus-glib' 'glu' 'gtk3' 'librsvg' 'wayland')
-makedepends=('cmake' 'git')
+depends=('curl' 'dbus-glib' 'glu' 'gtk3' 'librsvg' 'wayland' 'gtk-layer-shell')
+makedepends=('cmake' 'git' 'extra-cmake-modules')
optdepends=(
'wayfire-plugins-scale-ipc: Additional functionality on wayfire'
)
-provides=('cairo-dock')
-conflicts=('cairo-dock')
-source=("cairo-dock::git+https://github.com/dkondor/cairo-dock-core.git#branch=wayland_new")
+provides=("${pkgname%-git}" "cairo-dock")
+conflicts=("${pkgname%-git}" "cairo-dock")
+source=("${pkgname}::git+https://github.com/dkondor/cairo-dock-core.git#branch=wayland_new")
sha256sums=('SKIP')
-pkgver() {
- cd cairo-dock
+_builddir="build"
- tag='3.4.99'
- echo "${tag}.r$(git rev-list --count ${tag}..HEAD).$(git rev-parse --short HEAD)"
+pkgver () {
+ cd "${srcdir}/${pkgname}"
+ eval echo -n `grep -oP 'set\s*\(VERSION\s+\K(.*)(?=\))' CMakeLists.txt`
+ printf ".%s.%s" "$(TZ=UTC git log -1 --pretty='%cd' --date=format-local:%Y%m%d)" "$(git rev-parse --short HEAD)"
}
-build() {
- cd cairo-dock
+prepare() {
+ if [[ -d "${srcdir}/${pkgname}/${_builddir}" ]];
+ then
+ rm -rf "${srcdir}/${pkgname}/${_builddir}"
+ fi
+ mkdir "${srcdir}/${pkgname}/${_builddir}"
+}
- if [[ -d build ]]; then
- rm -rf build
- fi
- mkdir build && cd build
+build() {
+ cd "${srcdir}/${pkgname}/${_builddir}"
- cmake .. \
- -DCMAKE_BUILD_TYPE='Release' \
- -DCMAKE_INSTALL_PREFIX='/usr'
- make
+ cmake .. \
+ -DCMAKE_BUILD_TYPE='Release' \
+ -DCMAKE_INSTALL_PREFIX='/usr'
+ make -j$(nproc)
}
package() {
- cd cairo-dock/build
-
- make DESTDIR="${pkgdir}" install
+ cd "${srcdir}/${pkgname}/${_builddir}"
+
+ make DESTDIR="${pkgdir}" install
}