summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD37
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..760773924bbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = callaudiod-git
+ pkgdesc = Call audio routing daemon
+ pkgver = 0.0.4.r2.g6c8ffc2
+ pkgrel = 1
+ url = https://gitlab.com/mobian1/callaudiod
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ depends = alsa-lib
+ depends = glib2
+ depends = libpulse
+ provides = callaudiod
+ conflicts = callaudiod
+ source = git+https://gitlab.com/mobian1/callaudiod.git
+ md5sums = SKIP
+
+pkgname = callaudiod-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f41ade17b489
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=callaudiod-git
+pkgver=0.0.4.r2.g6c8ffc2
+pkgrel=1
+pkgdesc="Call audio routing daemon"
+arch=(i686 x86_64 armv7h aarch64)
+url="https://gitlab.com/mobian1/callaudiod"
+license=(GPL3)
+depends=(alsa-lib glib2 libpulse)
+makedepends=(git meson)
+provides=(callaudiod)
+conflicts=(callaudiod)
+source=("git+${url}.git")
+md5sums=(SKIP)
+
+prepare() {
+ ln -s ../src/callaudiod.h callaudiod/libcallaudio/callaudiod.h
+}
+
+pkgver() {
+ cd callaudiod
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson callaudiod build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}