summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD46
2 files changed, 42 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45158357abc2..ffc890a60b44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = calls-git
pkgdesc = Phone dialer and call handler
- pkgver = 0.0.1.r4.gee126b3
+ pkgver = 43.alpha.0.r1.ga2b08b6
pkgrel = 1
- url = https://source.puri.sm/Librem5/calls
- arch = i686
+ url = https://gitlab.gnome.org/GNOME/calls
arch = x86_64
- arch = armv6h
- arch = armv7h
+ arch = aarch64
license = GPL3
- depends = gsound
+ makedepends = git
+ makedepends = gobject-introspection
+ makedepends = meson
+ makedepends = vala
+ depends = callaudiod
+ depends = feedbackd
+ depends = folks
+ depends = gom
depends = libhandy
depends = libpeas
depends = modemmanager
+ depends = sofia-sip
provides = calls
conflicts = calls
- source = git+https://source.puri.sm/Librem5/calls.git
- md5sums = SKIP
+ source = git+https://gitlab.gnome.org/GNOME/calls.git
+ b2sums = SKIP
pkgname = calls-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 2766506268ad..26b58a8f2ee2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,47 @@
# Maintainer: Philip Goto <philip.goto@gmail.com>
pkgname=calls-git
-pkgver=0.0.1.r4.gee126b3
+pkgver=43.alpha.0.r1.ga2b08b6
pkgrel=1
-pkgdesc="Phone dialer and call handler"
-arch=(i686 x86_64 armv6h armv7h)
-url="https://source.puri.sm/Librem5/calls"
+pkgdesc='Phone dialer and call handler'
+arch=(x86_64 aarch64)
+url='https://gitlab.gnome.org/GNOME/calls'
license=(GPL3)
-depends=(gsound
- libhandy
- libpeas
- modemmanager)
-makedepends=()
+depends=(
+ callaudiod
+ feedbackd
+ folks
+ gom
+ libhandy
+ libpeas
+ modemmanager
+ sofia-sip
+)
+makedepends=(
+ git
+ gobject-introspection
+ meson
+ vala
+)
provides=(calls)
conflicts=(calls)
-source=("git+https://source.puri.sm/Librem5/calls.git")
-md5sums=(SKIP)
+source=("git+${url}.git")
+b2sums=(SKIP)
pkgver() {
- cd calls
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd calls
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- rm -rf build
- arch-meson calls build
- ninja -C build
+ arch-meson calls build -D tests=false
+ meson compile -C build
}
check() {
- ninja -C build test
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir/" ninja -C build install
+ DESTDIR="${pkgdir}" meson install -C build
}