summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
-rw-r--r--calmly-writer.sh13
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b182f0e4cb..7a4789240c7d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,17 +5,18 @@ pkgbase = calmly-writer-bin
url = https://www.calmlywriter.com
arch = aarch64
arch = x86_64
- license = custom
+ license = LicenseRef-custom
depends = electron24
depends = hicolor-icon-theme
depends = lib32-glibc
depends = lib32-gcc-libs
provides = calmly-writer=2.0.54
conflicts = calmly-writer
+ options = !strip
source = LICENSE.html::https://www.calmlywriter.com/eula.htm
source = calmly-writer.sh
sha256sums = 79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb
- sha256sums = 8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84
+ sha256sums = d4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231
source_aarch64 = calmly-writer_2.0.54-aarch64.deb::https://www.calmlywriter.com/releases/linux/deb/arm64/calmly-writer_2.0.54_arm64.deb
sha256sums_aarch64 = dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e
source_x86_64 = calmly-writer_2.0.54-x86_64.deb::https://www.calmlywriter.com/releases/linux/deb/x64/calmly-writer_2.0.54_amd64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 24a223f29115..e8293dda2552 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,9 +10,10 @@ arch=(
'x86_64'
)
url="https://www.calmlywriter.com"
-license=('custom')
+license=('LicenseRef-custom')
conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
+options=('!strip')
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
@@ -26,7 +27,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('79f277c107ca3402d156db2ced6ea619a966216097c8d4d17692bada193b3edb'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
sha256sums_aarch64=('dd7606298580fbf26c3882cdf83286db563680c9ef757cdceba6a605d8bbf11e')
sha256sums_x86_64=('91432bec316b83ef3a0e47815c4db9ec38903704e19c61e29f32782f327a3897')
build() {
@@ -35,7 +36,7 @@ build() {
-e "s|@appasar@|app.asar|g" \
-i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.xz"
- sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\" %U|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ sed "s|\"/opt/${_pkgname}/${pkgname%-bin}\"|${pkgname%-bin}|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
package() {
install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
diff --git a/calmly-writer.sh b/calmly-writer.sh
index 2ec4412e5c4f..aacd8f895847 100644
--- a/calmly-writer.sh
+++ b/calmly-writer.sh
@@ -1,14 +1,15 @@
-#!/bin/bash
+#!/bin/sh
set -e
_APPDIR="/usr/lib/@appname@"
+_ASAR="${_APPDIR}/@appasar@"
export PATH="${_APPDIR}:${PATH}"
-export ELECTRON_IS_DEV=0
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
-_ASAR="${_APPDIR}/@appasar@"
+export ELECTRON_IS_DEV=0
+export NODE_ENV=production
+cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" "$@"
else
- cd "${_APPDIR}"
exec electron@electronversion@ "${_ASAR}" --no-sandbox "$@"
-fi \ No newline at end of file
+fi
+exit \ No newline at end of file