summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD17
3 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2caca5adffa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = camel-k-bin
+ pkgdesc = Apache Camel K (a.k.a. Kamel) is a lightweight integration framework built from Apache Camel that runs natively on Kubernetes and is specifically designed for serverless and microservice architectures.
+ pkgver = 0.3.3
+ pkgrel = 1
+ url = https://github.com/apache/camel-k
+ arch = x86_64
+ license = Apache 2.0
+ source_x86_64 = https://github.com/apache/camel-k/releases/download/0.3.3/camel-k-client-0.3.3-linux-64bit.tar.gz
+ sha256sums_x86_64 = 7137a12c206be640268f564ff834fd1ffecace461954ae88cf357b420f52ebce
+
+pkgname = camel-k-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b2c13ebdac19
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+pkg
+src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..64c6ee63a156
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: winlu <derwinlu@gmail.com>
+
+pkgname=camel-k-bin
+pkgver=0.3.3
+pkgrel=1
+pkgdesc="Apache Camel K (a.k.a. Kamel) is a lightweight integration framework built from Apache Camel that runs natively on Kubernetes and is specifically designed for serverless and microservice architectures."
+url="https://github.com/apache/camel-k"
+license=('Apache 2.0')
+arch=('x86_64')
+
+source_x86_64=("https://github.com/apache/camel-k/releases/download/${pkgver}/camel-k-client-${pkgver}-linux-64bit.tar.gz")
+sha256sums_x86_64=('7137a12c206be640268f564ff834fd1ffecace461954ae88cf357b420f52ebce')
+
+
+package() {
+ install -Dm755 "$srcdir/kamel" "$pkgdir/usr/bin/kamel"
+}