summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD41
-rw-r--r--camocr.service10
4 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d74c5fe6a444
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = camo.cr-git
+ pkgdesc = A crystal version of atmos/camo, faster and with better request lifecycle tracing
+ pkgver = r41.0778b3e
+ pkgrel = 1
+ url = https://github.com/RX14/camo.cr
+ arch = i686
+ arch = x86_64
+ license = MIT
+ checkdepends = ruby
+ checkdepends = ruby-rake
+ checkdepends = ruby-bundler
+ makedepends = crystal
+ makedepends = shards
+ depends = gc
+ depends = libatomic_ops
+ depends = pcre
+ depends = libevent
+ source = git+https://github.com/RX14/camo.cr.git
+ source = camocr.service
+ sha256sums = SKIP
+ sha256sums = 61fdc0812e66e5a479fa486fbb75444d3a31ab684bc1372681f798c524fa0153
+
+pkgname = camo.cr-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5a62dcfabe77
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+camo.cr/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87f8c923a8b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jonne Haß <me@jhass.eu>
+pkgname=camo.cr-git
+pkgver=r41.0778b3e
+pkgrel=1
+pkgdesc="A crystal version of atmos/camo, faster and with better request lifecycle tracing"
+arch=('i686' 'x86_64')
+url="https://github.com/RX14/camo.cr"
+license=('MIT')
+depends=('gc' 'libatomic_ops' 'pcre' 'libevent')
+makedepends=('crystal' 'shards')
+checkdepends=('ruby' 'ruby-rake' 'ruby-bundler')
+backup=()
+source=("git+https://github.com/RX14/camo.cr.git" "camocr.service")
+
+pkgver() {
+ cd "${pkgname/-git/}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${pkgname/-git/}"
+ shards install
+}
+
+build() {
+ cd "${pkgname/-git/}"
+ shards build --release
+}
+
+check() {
+ cd "${pkgname/-git/}"
+ crystal spec
+}
+
+package() {
+ cd "${pkgname/-git/}"
+ install -Dm755 bin/camo "$pkgdir/usr/bin/camo"
+ install -Dm644 ../camocr.service "$pkgdir/usr/lib/systemd/system/camocr.service"
+}
+sha256sums=('SKIP'
+ '61fdc0812e66e5a479fa486fbb75444d3a31ab684bc1372681f798c524fa0153')
diff --git a/camocr.service b/camocr.service
new file mode 100644
index 000000000000..002dc2229bdc
--- /dev/null
+++ b/camocr.service
@@ -0,0 +1,10 @@
+[Unit]
+Description=a small http proxy to simplify routing images through an SSL host
+
+[Service]
+User=nobody
+EnvironmentFile=/etc/camo
+ExecStart=/usr/bin/camo
+
+[Install]
+WantedBy=multi-user.target