summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
-rw-r--r--dkms.conf8
3 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c09a723d4d76
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = can-isotp-dkms-git
+ pkgdesc = Kernel modules for isotp
+ pkgver = r14.6003f99
+ pkgrel = 1
+ url = https://github.com/hartkopp/can-isotp
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = dkms
+ optdepends = can-utils: utilities for sending and receiving ISOTP messges
+ optdepends = linux-headers: build the module against Arch kernel
+ optdepends = linux-lts-headers: build the module against LTS Arch kernel
+ provides = can-isotp-dkms
+ conflicts = can-isotp-dkms
+ source = git+https://github.com/hartkopp/can-isotp.git
+ source = dkms.conf
+ sha256sums = SKIP
+ sha256sums = 8224438ae2136eb5e423daf475168b337707539440c9024b97a9493c6c3e793e
+
+pkgname = can-isotp-dkms-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aab50db421d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Enrico Pozzobon <enricopozzobon@gmail.com>
+
+pkgname=can-isotp-dkms-git
+_pkgbase=can-isotp
+pkgver=r14.6003f99
+pkgrel=1
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+pkgdesc="Kernel modules for isotp"
+arch=('i686' 'x86_64')
+url="https://github.com/hartkopp/can-isotp"
+license=('GPL2')
+makedepends=('git')
+depends=('dkms')
+optdepends=('can-utils: utilities for sending and receiving ISOTP messges'
+ 'linux-headers: build the module against Arch kernel'
+ 'linux-lts-headers: build the module against LTS Arch kernel')
+source=("git+https://github.com/hartkopp/can-isotp.git"
+ 'dkms.conf')
+sha256sums=('SKIP'
+ '8224438ae2136eb5e423daf475168b337707539440c9024b97a9493c6c3e793e')
+
+pkgver() {
+ cd "$srcdir/${_pkgbase}"
+
+ # Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ # Install
+ install -dm755 "${pkgdir}/usr/src/${_pkgbase}-${pkgver}"
+ cp -r can-isotp/* "${pkgdir}/usr/src/${_pkgbase}-${pkgver}/"
+
+ # Copy dkms.conf
+ install -Dm644 dkms.conf "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+
+ # Set name and version
+ sed -e "s/@_PKGBASE@/${_pkgbase}/" \
+ -e "s/@PKGVER@/${pkgver}/" \
+ -i "${pkgdir}"/usr/src/${_pkgbase}-${pkgver}/dkms.conf
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dkms.conf b/dkms.conf
new file mode 100644
index 000000000000..923545719998
--- /dev/null
+++ b/dkms.conf
@@ -0,0 +1,8 @@
+PACKAGE_NAME="@_PKGBASE@"
+PACKAGE_VERSION="@PKGVER@"
+MAKE[0]="'make' modules"
+CLEAN="make clean"
+BUILT_MODULE_NAME[0]="@_PKGBASE@"
+DEST_MODULE_LOCATION[0]="/kernel/drivers/net/can"
+BUILT_MODULE_LOCATION[0]="./net/can"
+AUTOINSTALL="yes"