summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--cannonball.sh5
3 files changed, 11 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b955b648b10..bd5bd14cb495 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -17,6 +17,6 @@ pkgbase = cannonball
source = cannonball.sh
sha256sums = e2cf8e21619b183a9fd835ae34ce65fb3d014c2fea37723fc8ba05681ed317ce
sha256sums = 04d0c0e9252bccfef97bb59c9e89376461f9b52845570b2ebc14610ce74cf1ff
- sha256sums = 787fdfef544e41f5c358afb1a8d31bf22d0ff48631467b590f046dbcd9fc45af
+ sha256sums = 81f2a1a4e473c87272ce9321dfc616614760dc4c7a0d367d167413e3a71ec8b9
pkgname = cannonball
diff --git a/PKGBUILD b/PKGBUILD
index 4921cfa3021d..1e90973d4695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,7 +15,7 @@ source=($pkgname-$pkgver.tar.gz::"https://github.com/djyt/cannonball/archive/v$p
"$pkgname.sh")
sha256sums=('e2cf8e21619b183a9fd835ae34ce65fb3d014c2fea37723fc8ba05681ed317ce'
'04d0c0e9252bccfef97bb59c9e89376461f9b52845570b2ebc14610ce74cf1ff'
- '787fdfef544e41f5c358afb1a8d31bf22d0ff48631467b590f046dbcd9fc45af')
+ '81f2a1a4e473c87272ce9321dfc616614760dc4c7a0d367d167413e3a71ec8b9')
prepare() {
cd $pkgname-$pkgver
@@ -37,6 +37,10 @@ package() {
install -Dm644 res/icon.png "$pkgdir"/usr/share/icons/hicolor/256x256/apps/$pkgname.png
install -Dm755 ../$pkgname.sh "$pkgdir"/usr/bin/$pkgname
install -Dm755 build/$pkgname "$pkgdir"/usr/lib/$pkgname/$pkgname
+
+ # widescreen tilemap data
+ install -d "$pkgdir"/usr/share/${pkgname%-*}/res
+ install -m644 res/*.bin "$pkgdir"/usr/share/${pkgname%-*}/res
# configuration file
install -Dm644 build/config.xml "$pkgdir"/usr/share/$pkgname/config.xml
diff --git a/cannonball.sh b/cannonball.sh
index 6f773399fcf6..80a4d46cc00b 100644
--- a/cannonball.sh
+++ b/cannonball.sh
@@ -11,5 +11,10 @@ if [ ! -f ~/.cannonball/config.xml ]; then
cp /usr/share/cannonball/config.xml ~/.cannonball
fi
+# widescreen tilemaps
+if [ ! -h ~/.cannonball/res ]; then
+ ln -s /usr/share/cannonball/res ~/.cannonball
+fi
+
# run the game
cd ~/.cannonball && exec /usr/lib/cannonball/cannonball "$@"