summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
2 files changed, 2 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb897406f101..d9c09d4286a2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,4 +20,3 @@ pkgbase = canorus-git
sha256sums = SKIP
pkgname = canorus-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c1db19c5d282..02f27c7aef6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -26,8 +26,9 @@ build() {
cd "$srcdir/${pkgname%-git}"
# stringop-truncation will be fixes in swig, see https://github.com/swig/swig/issues/893
export CXXFLAGS+=" -Wno-misleading-indentation -Wno-dangling-else -Wno-stringop-truncation -Wno-deprecated -Wno-deprecated-declarations"
+# See https://github.com/canorusmusic/canorus/issues/182
cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
- -DDEFAULT_DATA_DIR="/usr/share/canorus"
+ -DDEFAULT_DATA_DIR="/usr/share/canorus" -DNO_PYTHON=1
make
}