summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD42
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bb897406f101
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = canorus-git
+ pkgdesc = A free music score editor
+ pkgver = r1479.3ccb8921
+ pkgrel = 1
+ url = http://www.canorus.org/
+ arch = x86_64
+ license = GPL
+ makedepends = qt5-tools>=5.6
+ makedepends = cmake>=3.5
+ makedepends = swig>=3.0.8
+ makedepends = git
+ depends = qt5-svg>=5.6
+ depends = qt5-webengine>=5.6
+ depends = alsa-lib
+ depends = zlib
+ depends = python>=3
+ provides = canorus
+ conflicts = canorus
+ source = git+https://github.com/canorusmusic/canorus.git
+ sha256sums = SKIP
+
+pkgname = canorus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1db19c5d282
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Clemmitt Sigler <cmsigler (dot) online (at) gmail (dot) com>
+
+pkgname=canorus-git
+pkgver=r1479.3ccb8921
+pkgrel=1
+pkgdesc="A free music score editor"
+arch=('x86_64')
+url="http://www.canorus.org/"
+license=('GPL')
+depends=('qt5-svg>=5.6' 'qt5-webengine>=5.6' 'alsa-lib' 'zlib' 'python>=3')
+makedepends=('qt5-tools>=5.6' 'cmake>=3.5' 'swig>=3.0.8' 'git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/canorusmusic/canorus.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ # stringop-truncation will be fixes in swig, see https://github.com/swig/swig/issues/893
+ export CXXFLAGS+=" -Wno-misleading-indentation -Wno-dangling-else -Wno-stringop-truncation -Wno-deprecated -Wno-deprecated-declarations"
+ cmake . -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX="$pkgdir"/usr \
+ -DDEFAULT_DATA_DIR="/usr/share/canorus"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make install
+ install -d "$pkgdir"/usr/share/{applications,pixmaps}
+ cp canorus.desktop "$pkgdir"/usr/share/applications
+ cp "$pkgdir"/usr/share/{canorus/images/clogosm.png,pixmaps/canorus.png}
+}
+
+# vim:set ts=2 sw=2 ft=sh et: