summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile18
-rw-r--r--PKGBUILD8
3 files changed, 23 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 49e267be9815..edca45979d38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = cantata-git
pkgdesc = Qt5 graphical client for Music Player Daemon (MPD) - git version.
- pkgver = 2.3.3.r35.g4c1b8fd49
+ pkgver = 2.5.0.r7607.e2a8aa496
pkgrel = 1
- url = https://github.com/cdrummond/cantata
+ url = https://github.com/fenuks/cantata
arch = i686
arch = x86_64
arch = aarch64
@@ -26,7 +26,7 @@ pkgbase = cantata-git
optdepends = ffmpeg: ReplayGain support
provides = cantata
conflicts = cantata
- source = cantata-git::git+https://github.com/CDrummond/cantata.git
+ source = cantata-git::git+https://github.com/fenuks/cantata.git
sha256sums = SKIP
pkgname = cantata-git
diff --git a/Makefile b/Makefile
index 08756c98350b..6073b72eb45d 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,9 @@
+.SHELL = /usr/bin/env bash
+
+NAME = "$(shell grep -m 1 pkgname .SRCINFO | cut -d '=' -f 2 | xargs)"
+URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | xargs)"
+VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | xargs)"
+
.PHONY: all
all: build git install
@@ -16,7 +22,7 @@ srcinfo:
.PHONY: makepkg
makepkg:
- makepkg -s
+ makepkg --syncdeps --force
.PHONY: build
build: geninteg srcinfo makepkg
@@ -29,7 +35,6 @@ git_add:
git add PKGBUILD .SRCINFO Makefile
.PHONY: git_commit
-git_commit: VERSION = "$(shell grep pkgver .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')"
git_commit: GIT_STATUS = "$(shell git status --porcelain)"
git_commit:
[ -n ${GIT_STATUS} ] && git commit -m "Update to ${VERSION}"
@@ -39,6 +44,13 @@ install:
makepkg --repackage --install --force
.PHONY: open
-open: URL = "$(shell grep url .SRCINFO | cut -d '=' -f 2 | tr -d '[:space:]')"
open:
xdg-open $(URL)
+
+.PHONY: run
+run:
+ env $(NAME)
+
+.PHONY: test
+test:
+ env $(NAME) --version
diff --git a/PKGBUILD b/PKGBUILD
index 0e68310f7515..55b6be3403b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: goetzc
# Maintainer: Kim Scarborough <sluggo@unknown.nu>
pkgname=cantata-git
-pkgver=2.5.0.r7590.af04723c0
+pkgver=2.5.0.r7607.e2a8aa496
pkgrel=1
pkgdesc="Qt5 graphical client for Music Player Daemon (MPD) - git version."
arch=('i686' 'x86_64' 'aarch64' 'armv7h')
-url="https://github.com/cdrummond/cantata"
+url="https://github.com/fenuks/cantata"
license=(GPL3)
depends=(qt5-multimedia
qt5-svg
@@ -24,10 +24,12 @@ optdepends=('perl-uri: Dynamic playlist'
makedepends=(git cmake qt5-tools ffmpeg)
conflicts=(cantata)
provides=(cantata)
-source=("$pkgname::git+https://github.com/CDrummond/cantata.git")
+source=("$pkgname::git+${url}.git")
pkgver() {
cd "${pkgname}"
+ # Add missing Git tag
+ git tag -f v2.5.0 46a6c7b5ec46184288a3efde8245921f36777146
printf "%s.r%s.%s" "$(git tag | tail -n 1 | sed 's/^v//')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}