summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD44
-rw-r--r--cantera-git.install41
3 files changed, 44 insertions, 56 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b17f3383bc72..a358d2fe2e9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = cantera-git
pkgdesc = suite of tools for kinetics, thermodynamics, and transport processes
- pkgver = 2.4.0.r689.g29437efc4
- pkgrel = 2
+ pkgver = 2.5.1.r0.gb0bace782
+ pkgrel = 1
url = https://cantera.org/
install = cantera-git.install
arch = x86_64
@@ -10,19 +10,18 @@ pkgbase = cantera-git
license = custom:California Institute of Technology
checkdepends = gtest
checkdepends = gmock
+ checkdepends = python-ruamel-yaml
makedepends = scons
makedepends = git
makedepends = gcc
makedepends = fmt
- depends = python
+ makedepends = doxygen
depends = eigen
depends = sundials
depends = boost
- optdepends = python-numpy: numerical python support
- optdepends = cython: compiler for python interface
- optdepends = python-ruamel-yaml: cython support
- optdepends = doxygen: documentation
- optdepends = tcsh: csh scripts
+ depends = tcsh
+ depends = cython
+ depends = python-numpy
provides = libcantera_shared.so=2-64
source = git+https://github.com/Cantera/cantera.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7e079ca04803..86a65462cc0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,29 @@
-# Maintainer: Tobias Baust <tobias.baust at tutanota dot com>
+# Maintainer: Tobias M. Baust <tobias.baust at tutanota dot com>
_pkgname=cantera
pkgname="${_pkgname}-git"
-pkgver='2.4.0.r689.g29437efc4'
-pkgrel=2
+pkgver='2.5.1.r0.gb0bace782'
+pkgrel=1
pkgdesc='suite of tools for kinetics, thermodynamics, and transport processes'
arch=('x86_64')
url='https://cantera.org/'
license=('custom:Cantera Developers'
'custom:Sandia Corporation Contract AC04-94AL85000'
'custom:California Institute of Technology')
-depends=('python' 'eigen' 'sundials' 'boost')
-makedepends=('scons' 'git' 'gcc' 'fmt')
-checkdepends=('gtest' 'gmock')
-optdepends=('python-numpy: numerical python support'
- 'cython: compiler for python interface'
- 'python-ruamel-yaml: cython support'
- 'doxygen: documentation'
- 'tcsh: csh scripts')
+depends=('eigen' 'sundials' 'boost' 'tcsh' 'cython' 'python-numpy')
+makedepends=('scons' 'git' 'gcc' 'fmt' 'doxygen')
+checkdepends=('gtest' 'gmock' 'python-ruamel-yaml')
provides=('libcantera_shared.so=2-64')
install="$pkgname.install"
source=(git+https://github.com/Cantera/cantera.git)
md5sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "$_pkgname"
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$_pkgname"
+ cd "$_pkgname"
# build cantera
scons build \
prefix="$pkgdir/usr" \
@@ -38,33 +33,22 @@ build() {
googletest='system' \
extra_inc_dirs='/usr/include/eigen3'
# build documentation
- $(pacman -Qi doxygen &> /dev/null)
- if [ "$?" -eq "0" ]; then
- scons doxygen
- fi
+ scons doxygen
# build cantera samples
scons samples
}
check() {
- cd "$_pkgname"
- $(pacman -Qi python-numpy &> /dev/null) && \
- $(pacman -Qi python-ruamel-yaml &> /dev/null) && \
- $(pacman -Qi cython &> /dev/null)
- if [ "$?" -ne "0" ]; then
- # run tests without python
- scons test-help | grep "test-" | sed '/python/d' | xargs scons
- else
- # run all tests
- scons test
- fi
+ cd "$_pkgname"
+ scons test
}
package() {
- cd "$_pkgname"
+ cd "$_pkgname"
install -Dm644 License.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# install cantera
scons install
# correct namcap warning directory-not-world-executable
- chmod 755 "$pkgdir/usr/lib/python3.8/site-packages"
+ _python_v=$(python -V | awk '{print $2}')
+ chmod 755 "$pkgdir/usr/lib/python${_python_v:0:3}/site-packages"
}
diff --git a/cantera-git.install b/cantera-git.install
index e31dcac49d03..ea191b3cede6 100644
--- a/cantera-git.install
+++ b/cantera-git.install
@@ -1,22 +1,27 @@
post_install() {
+ _python_v=$(python -V | awk '{print $2}')
echo "
- File locations:
-
- applications /usr/bin
- library files /usr/lib
- C++ headers /usr/include
- samples /usr/share/cantera/samples
- data files /usr/share/cantera/data
- Python package (cantera) /usr/lib/python3.8/site-packages
- Python samples /usr/lib/python3.8/site-packages/cantera/examples
- Setup scripts to configure the environment for Cantera are at:
- setup script (bash) /usr/bin/setup_cantera
- setup script (csh/tcsh) /usr/bin/setup_cantera.csh
-
- It is recommended that you run the script for your shell by typing:
-
- source /usr/bin/setup_cantera
-
- before using Cantera, or else include its contents in your shell login script.
+ Cantera has been successfully installed.
+
+ File locations:
+
+ applications /usr/bin
+ library files /usr/lib
+ C++ headers /usr/include
+ samples /usr/share/cantera/samples
+ data files /usr/share/cantera/data
+ Python package (cantera) /usr/lib/python${_python_v:0:3}/site-packages
+ Python samples /usr/lib/python${_python_v:0:3}/site-packages/cantera/examples
+
+ Setup scripts to configure the environment for Cantera are at:
+
+ setup script (bash) /usr/bin/setup_cantera
+ setup script (csh/tcsh) /usr/bin/setup_cantera.csh
+
+ It is recommended that you run the script for your shell by typing:
+
+ source /usr/bin/setup_cantera
+
+ before using Cantera, or else include its contents in your shell login script.
"
}